Results 1 to 3 of 3
  1. #1
    thetolleyman's Avatar
    Join Date
    Jul 2010
    Location
    Williamsburg, VA
    Posts
    562
    +1
    2

    GTX RFI rectifier troubles

    My "Low-Voltage" warning has been flashing for a while. I finally picked up a used rectifer. Installed it, the warning light did not come on at first, but after only one minute or so the warning is back on and will not cut off. Battery voltage at 5500 rpms spikes above 15, I even got a 16.6 reading momentarily.

    Is there another component that can cause my rectifiers to fail quickly, or did I just buy a bum one off ebay?

    ST


  2. #2
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    Get a new one,used electric parts are a gamble.

  3. #3
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    check all your neg and pos cables.
    both ends.
    at battery and on the block.
    make sure the neg ground locations on the block are good.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GTX RFI problem
    By PWCGEEK in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 09-22-2010, 02:10 PM
  2. 98 GTX RFI fuel filter
    By Tonic in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 08-15-2007, 07:38 AM
  3. Running out of ideas and patience with 98 GTX RFI
    By Tonic in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 08-13-2007, 02:18 PM
  4. grrr more rectifier troubles
    By speedsterpimpin in forum Sea Doo Sport Boats
    Replies: 5
    Last Post: 05-14-2007, 07:42 PM
  5. Parasitic draw 02 GTX RFI
    By WFO in forum 4-Tec Performance
    Replies: 6
    Last Post: 09-08-2006, 06:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •