Results 1 to 6 of 6
  1. #1
    Norwegian Wiking Trond's Avatar
    Join Date
    Nov 2007
    Location
    Norway, Kristiansand
    Posts
    1,456

    switched A and B on ECU!! oh no

    When helping my friend putting his ski together after changing the flywheel bolts, he mixed the A and the B on the ECU... I left that job to him as i was sure that the contacts could not be swithed. Well... now the buzzer is gone and the display is not showing much. Could he have fried something, or is there a fuse somewhere? I checked the fuses in the front, but i might have overlooked one... The ski fires right up and runs good.

    Help!!


  2. #2
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by Trond View Post
    When helping my friend putting his ski together after changing the flywheel bolts, he mixed the A and the B on the ECU... I left that job to him as i was sure that the contacts could not be swithed. Well... now the buzzer is gone and the display is not showing much. Could he have fried something, or is there a fuse somewhere? I checked the fuses in the front, but i might have overlooked one... The ski fires right up and runs good.

    Help!!
    I did that once when not paying attention in a hurry. Noticed it when I went to start the ski and got a long beep. Switched it back and everything worked fine. This was on a 05. Maybe I got lucky.

  3. #3
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    you can check your fuses at the mpem but most likely you either have a damaged pin from cross connecting or The ecu got f=damaged

  4. #4
    Norwegian Wiking Trond's Avatar
    Join Date
    Nov 2007
    Location
    Norway, Kristiansand
    Posts
    1,456
    If it burned anything i hope its in the cluster and not the ecu... except from the buzzer and cluster, the rest seems to work just fine.

  5. #5
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    I thought you could not mix them up? Guess you can

  6. #6
    Norwegian Wiking Trond's Avatar
    Join Date
    Nov 2007
    Location
    Norway, Kristiansand
    Posts
    1,456
    Quote Originally Posted by GOLD06RXP View Post
    I thought you could not mix them up? Guess you can

    Yeah, i guess you can... it doesnt go on as easy as the the correct way, but it goes on. pretty stupid if u ask me

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS 09 and 07 turbo for sale no reserve on Ebay
    By XRIDER in forum Honda Skis
    Replies: 1
    Last Post: 08-15-2010, 01:20 PM
  2. FS 2010 rxtx 260 and IS models ecu rs no gps limiter
    By rxpstan in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 08-05-2010, 08:19 AM
  3. bleeps and dash on, with no lanyard
    By jetskibill9999 in forum 4-Tec Performance
    Replies: 3
    Last Post: 11-17-2008, 07:49 PM
  4. Speed Limit on the Chain- oh no!
    By BudLightBunnY in forum Open Discussion
    Replies: 21
    Last Post: 12-18-2007, 09:53 AM
  5. ECU up and running on RXP
    By Jrsrxp in forum 4-Tec Performance
    Replies: 15
    Last Post: 04-16-2006, 12:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •