Results 1 to 3 of 3
  1. #1
    WTFO GvillePWCguy's Avatar
    Join Date
    May 2008
    Location
    Gainesville, GA
    Posts
    146

    RXT Electrical Questions

    1) Ok so I finally got my 05 RXT put back together. When I put the key in it just gives me one long deep but nothing comes up on the display and there is no response when I press any of the buttons. Does anybody have any idea what could be going on?

    2) We checked the wiring diagram to try to track down to see if anything happen to be missing. We couldnt locate where the "power supply cut-off relay" is. Does anybody know where that would be located? It wouldnt be inside the MPEM would it?

    If anybody knows anything about this or has any ideas dont hesitate to post. Thanks


  2. #2
    You have the wrong key, a bad key, or a bad DESS post. The ECU sees a key, but does not recognize it.

    The cutoff relay on a 2005 is internal to the MPEM. They used an external relay starting in 2006.

  3. #3
    WTFO GvillePWCguy's Avatar
    Join Date
    May 2008
    Location
    Gainesville, GA
    Posts
    146
    Ok awesome. Thanks for the info!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXT handling question
    By MPower in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-11-2009, 10:04 AM
  2. Electrical question
    By absentx in forum Polaris Open Discussion
    Replies: 2
    Last Post: 03-30-2007, 08:52 PM
  3. RXT prop questions
    By Mark S in forum 4-Tec Performance
    Replies: 12
    Last Post: 09-23-2006, 09:35 AM
  4. RXT handling question
    By weltonw in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 05-29-2006, 04:23 PM
  5. RXT repitche question
    By amirmiz in forum 4-Tec Performance
    Replies: 7
    Last Post: 02-08-2006, 04:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •