Results 1 to 3 of 3
  1. #1

    Unhappy RXP electrical faults

    I have 2006 rxp slightly modified with c kit - the problem i'm having is that once the craft warms up it runs sweet at 8450rpm and 16psi boost, after about 5mins thenshows fault code 351 which is coil 1 and or 12v earth - I have changed coils and still shows fault after testing....... any ideas on the problem?

  2. #2
    home of the dislexic fingers breon's Avatar
    Join Date
    Aug 2007
    port st lucie fl
    check the wiring you probably have a short there ..or corrosion an a pin in the ecu

  3. #3

    Join Date
    Jul 2009
    Auckland New Zealand

    Thumbs up RXP Fault

    Suggest you ride it for only 4 minutes at a time and it will be sweet, go hard for shorter time, !!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. BUDS faults
    By MyTSiTalon in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 06-26-2008, 04:09 PM
  2. Electrical help
    By jeffsntx in forum Conversion PWC Performance Skis
    Replies: 12
    Last Post: 04-20-2008, 09:30 PM
  3. 05 RXP electrical problem
    By Roger H in forum 4-Tec Performance
    Replies: 1
    Last Post: 01-27-2008, 09:23 PM
  4. Faults and build dates- any improvement?
    By fairlanex in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 08-24-2007, 06:33 AM
  5. 97 xp electrical
    By Stoffa17 in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-21-2007, 12:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts