Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    tysonfzr's Avatar
    Join Date
    Nov 2009
    Location
    johor bahru malaysia
    Posts
    621

    Finally my engine start moving!^_^





    not yet test on water,will update the result soon ^_^


  2. #2
    MR MAC's Avatar
    Join Date
    Feb 2010
    Location
    Essex, England
    Posts
    450
    vid dont seam to work for me

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Very good Tyson

  4. #4
    gmoeller's Avatar
    Join Date
    Nov 2007
    Location
    Hermosa Beach, Calif
    Posts
    1,450
    +1
    9


    So far so good!

  5. #5
    I wanna go fast perk_1405's Avatar
    Join Date
    Nov 2009
    Location
    winnabow, nc
    Posts
    202
    what mods did you do?

  6. #6
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    Best of luck !

  7. #7
    tysonfzr's Avatar
    Join Date
    Nov 2009
    Location
    johor bahru malaysia
    Posts
    621
    Quote Originally Posted by Green Hulk View Post
    Very good Tyson
    thank u for ur help n advice jerry
    Quote Originally Posted by gmoeller View Post


    So far so good!
    tks buddy for ur advice

    Quote Originally Posted by perk_1405 View Post
    what mods did you do?
    i took out the whole engine n dismantle it due to my previous oil problem n fix it back with the Riva engine upgrade kit,Racing cams,RRFPR,Riva waterbox

    Quote Originally Posted by SHOBiz View Post
    Best of luck !
    tks buddy for ur advice

  8. #8
    abracadabra's Avatar
    Join Date
    Oct 2008
    Location
    Wellington, FL United States of America
    Posts
    2,046
    +1
    180

    Thumbs up Nice work

    Quote Originally Posted by tysonfzr View Post




    not yet test on water,will update the result soon ^_^
    Way to go Tyson!!! Now get that thing on the water and show us what those racing cams can do Good luck, Julio...

  9. #9
    tysonfzr's Avatar
    Join Date
    Nov 2009
    Location
    johor bahru malaysia
    Posts
    621
    Quote Originally Posted by abracadabra View Post
    Way to go Tyson!!! Now get that thing on the water and how us what those racing cams can do Good luck, Julio...
    sure buddy!

  10. #10
    tysonfzr's Avatar
    Join Date
    Nov 2009
    Location
    johor bahru malaysia
    Posts
    621
    toady i took for my ski for break in after "she" rested for such a long time lol...
    when the engine starts it was abit soft but when throttle it slowly become more powerful n when above rpm 5000 the mid was superb
    the throttle respond was so light n fast!its like u juz throttle n it goes zoom.....
    im using skat 13/25 now,i think im goin to send my dyna 13/22r to repitch to 13/23 for the rpm to go up...
    however there is still afew drop of oil coming out from the breather kit mayb i should check the oil level again...

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. finally found engine for my yamaha fxho
    By Seakid in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 12-14-2014, 08:24 PM
  2. Starting to rebuild my engine
    By MrIgor in forum 4-Tec Performance
    Replies: 1
    Last Post: 11-17-2012, 02:16 AM
  3. My engine came in today *pics*
    By Green Hulk in forum 4-Tec Performance
    Replies: 47
    Last Post: 04-14-2006, 10:49 PM
  4. oh shit my engine
    By stickem in forum 4-Tec Performance
    Replies: 35
    Last Post: 03-14-2006, 06:10 PM
  5. Cracked my engine open *Pics*
    By Green Hulk in forum 4-Tec Performance
    Replies: 33
    Last Post: 02-15-2006, 03:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •