Results 1 to 4 of 4
  1. #1
    b_dolla44's Avatar
    Join Date
    Apr 2008
    Location
    Noblesville, Indiana United States
    Posts
    1,165
    +1
    15

    04 RXP with Riva ECU randomly turns on by itself! No key on DESS plug... Help???

    So I took the ski out on last friday for the end of the year run... The Rxp wouldn't run at WOT for longer than 10 seconds without getting a high temp alarm...no biggie... as im sure it's because of the Riva gen1 IC that im running...
    Moving on from that i load up the ski and leave it outside friday night/saturday. As I load back up and make the hour and 45 min drive back to Indianapolis. I pull in, unhook the ski... put it in the garage and i hear this beep...it takes a sec to figure where its coming from... but i walk over to the ski and it's randomly turning on/off. Just like i was plugging in the key to the DESS post. It got to the point that it would no longer turn off... it would just stay on... it would even crank over the engine if i hit the start/stop buttom....so i unhooked the battary and waited 5-10 secs... hooked it back up and still did it...hmmm????.... .i let it sit over night unhooked from sat-monday... and now it's not doing it anymore... anyone ever heard of this??? Im thinking DESS post. But before i get out the DVOM and voltage drop/ check for power im hoping someone has some insight on where to start...


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    You need a new DESS post

  3. #3
    b_dolla44's Avatar
    Join Date
    Apr 2008
    Location
    Noblesville, Indiana United States
    Posts
    1,165
    +1
    15
    Quote Originally Posted by Green Hulk View Post
    You need a new DESS post
    Thanks Jerry! Is this a common problem???

  4. #4
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by b_dolla44 View Post
    Thanks Jerry! Is this a common problem???
    I wouldn't say it's common, but I have seen it happen several times.

    The DESS post is item 7 on this page of the store
    http://partsfinder.onlinemicrofiche....=13&A=118&B=29

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SOLD 2007 RXP with Riva ECU, 08 up exhaust and other goodies. $6200
    By Water4fire in forum Sea Doo 4Tec Skis
    Replies: 15
    Last Post: 08-05-2013, 10:44 AM
  2. Replies: 6
    Last Post: 06-16-2011, 05:34 AM
  3. Replies: 4
    Last Post: 06-12-2011, 08:29 AM
  4. turning stock springs and retainers @ 8600 with riva ecu???
    By b_dolla44 in forum 4-Tec Performance
    Replies: 23
    Last Post: 10-05-2010, 07:40 PM
  5. 05 rxp with riva ecu ?????? on Timing
    By rxpvic in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-14-2010, 09:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •