Results 1 to 8 of 8
  1. #1
    tealgreen2000's Avatar
    Join Date
    Jul 2010
    Location
    miami gardens
    Posts
    305
    +1
    8

    sho rev problrem

    i've got and sho with 11hrs ski revs like it was in L mode got the keys programmed to turn it off. It ran good for like ten mins then went back to running like its in L mode again but the light isnt on for L mode. The motor revs lazy the ski wont go more than 10-15mph just like L mode. anyone had this happen or any ideas what to check or do thanks for any advice


  2. #2
    old school gp's Avatar
    Join Date
    Jun 2010
    Location
    miami
    Posts
    705
    Quote Originally Posted by tealgreen2000 View Post
    i've got and sho with 11hrs ski revs like it was in L mode got the keys programmed to turn it off. It ran good for like ten mins then went back to running like its in L mode again but the light isnt on for L mode. The motor revs lazy the ski wont go more than 10-15mph just like L mode. anyone had this happen or any ideas what to check or do thanks for any advice
    Sell me the motor let me put it in my hull and see if it happens to me, thats 1 way u can get rid of that rev PROBLEM

  3. #3
    tealgreen2000's Avatar
    Join Date
    Jul 2010
    Location
    miami gardens
    Posts
    305
    +1
    8

    man down

    yea u can have all my old hosrepower

  4. #4
    Just want to ride.
    Join Date
    Dec 2005
    Location
    Sumner, WA
    Posts
    413
    +1
    5

    Check Exhaust

    Hey there,

    I would take a quick look at your exhaust clamps - if the boat will run better with the seat off, you have an exhaust leak. I had the waterbox hose pop off my FZR and it wouldn't run for crap unless the seat was off, so it could get fresh air.

    It's a slim chance, but that might be your issue.

    Good luck!
    Sean

  5. #5
    MR MAC's Avatar
    Join Date
    Feb 2010
    Location
    Essex, England
    Posts
    450
    Clutch???

  6. #6

    Join Date
    Aug 2008
    Location
    Southern Florida
    Posts
    5,589
    +1
    345
    Quote Originally Posted by MR MAC View Post
    Clutch???
    Yeah, check to see if you SC wheel spins only in one direction by pulling off the air intake. If your SC wheel only spins in one direction check to see if a supercharger hose blow off.

  7. #7
    tealgreen2000's Avatar
    Join Date
    Jul 2010
    Location
    miami gardens
    Posts
    305
    +1
    8
    ive checked the supercharger clutch its good the exaust is good ive changed the coils plugs checked the throttle body perfect i changed the madule(lilttle black box in the front of the ski) the ski started reving perfect went to ride ran good for like ten mins then started back doing the same thing any ideas what is happening

  8. #8
    lets race.... mikeFZR's Avatar
    Join Date
    Mar 2009
    Location
    MA
    Posts
    4,130
    +1
    205
    Quote Originally Posted by tealgreen2000 View Post
    ive checked the supercharger clutch its good the exaust is good ive changed the coils plugs checked the throttle body perfect i changed the madule(lilttle black box in the front of the ski) the ski started reving perfect went to ride ran good for like ten mins then started back doing the same thing any ideas what is happening
    Hook it up to YIDS or bring it to a dealer.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. help needed on a 2009 fx sho revs and speed
    By darren 4tec in forum Yamaha PWC Performance (4-stroke)
    Replies: 11
    Last Post: 05-01-2013, 04:29 PM
  2. 09 sho rev limiter
    By FXSlowKroozer in forum Yamaha PWC Performance (4-stroke)
    Replies: 14
    Last Post: 09-05-2012, 09:16 AM
  3. Sho Rev Limit Issues
    By anarchy101 in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 09-06-2008, 10:40 AM
  4. How many SHOs are hitting the rev limiter?
    By fussy1 in forum Yamaha PWC Performance (4-stroke)
    Replies: 10
    Last Post: 08-11-2008, 02:51 AM
  5. SHO mid rev vibration
    By EL TEL in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 06-23-2008, 09:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •