Results 1 to 5 of 5
  1. #1
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28

    Fuel rail bolt issue

    Hey guys, went to change out my injectors today with the bosch 48#.
    Having done all the hard work with the s/c impeller and what not, i was looking forward to the easy task of changing the injectors. turned out not to be the case. Whilst the rear injector rail bolt came out no problem, the front one was just free spinning.
    After a fair amount of stuffing around, i lost my patience, grabbed a set of vice grips, stood over the ski and twisted and reefed the bloody thing til it popped out.
    Click image for larger version. 

Name:	IMG_0410.jpg 
Views:	73 
Size:	61.3 KB 
ID:	221193

    Not too sure why this happened, i guess it wasnt secured properly from the factory. Any advice as to what i should use to hold it tight in place? For now i have just tapped it back into place with the new injectors fitted..

    Cheers


  2. #2

    Join Date
    Jan 2009
    Location
    Scotland, UK
    Posts
    290
    +1
    9

    Smile

    Quote Originally Posted by monaroman76 View Post
    Hey guys, went to change out my injectors today with the bosch 48#.
    Having done all the hard work with the s/c impeller and what not, i was looking forward to the easy task of changing the injectors. turned out not to be the case. Whilst the rear injector rail bolt came out no problem, the front one was just free spinning.
    After a fair amount of stuffing around, i lost my patience, grabbed a set of vice grips, stood over the ski and twisted and reefed the bloody thing til it popped out.
    Click image for larger version. 

Name:	IMG_0410.jpg 
Views:	73 
Size:	61.3 KB 
ID:	221193

    Not too sure why this happened, i guess it wasnt secured properly from the factory. Any advice as to what i should use to hold it tight in place? For now i have just tapped it back into place with the new injectors fitted..

    Cheers
    Exactly the same thing happened to my T-X. I managed to get the insert of the bolt and then using a junior hacksaw blade, made 2 or 3 small vertical cuts inside the hole that the insert goes into. I then used a two part epoxy glue (araldite i think) and coated the insert and the hole. Fitted the insert back into the hole and allowed the glue to set up overnight. Worked a dream and ive removed the rail and the injectors several times since. Hope this helps you.

  3. #3
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Quote Originally Posted by heckie View Post
    Exactly the same thing happened to my T-X. I managed to get the insert of the bolt and then using a junior hacksaw blade, made 2 or 3 small vertical cuts inside the hole that the insert goes into. I then used a two part epoxy glue (araldite i think) and coated the insert and the hole. Fitted the insert back into the hole and allowed the glue to set up overnight. Worked a dream and ive removed the rail and the injectors several times since. Hope this helps you.
    That does help, thankyou. Must have been a common factory defect with the 08's. Do you think the araldite would still hold without the vertical cuts?
    Anyone else have this problem?

  4. #4

    Join Date
    Jan 2009
    Location
    Scotland, UK
    Posts
    290
    +1
    9
    Quote Originally Posted by monaroman76 View Post
    That does help, thankyou. Must have been a common factory defect with the 08's. Do you think the araldite would still hold without the vertical cuts?
    Anyone else have this problem?
    It might do. I just make the cuts to make sure it would. You could also roughen up the outside of the insert aswell, just to give the araldite something to get into...it will give it something to hold onto.

  5. #5
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    dont forget to use some never seize on the threads next time you install.
    and dont overtighten!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2 bolts for fuel rail and injectors 4-tec
    By wkuadam07 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 10-07-2014, 03:09 PM
  2. Stripped Fuel Rail Bolts -- What To Do???
    By jerseyshore in forum Sea Doo Open Discussion
    Replies: 37
    Last Post: 10-07-2009, 05:55 PM
  3. Replies: 14
    Last Post: 08-03-2009, 11:06 PM
  4. i need a 2007 rxp part that the fuel rail bolts screw into...
    By jerseyshore in forum 4-Tec Performance
    Replies: 0
    Last Post: 10-30-2008, 07:57 PM
  5. 300HP kit double fuel rail pics
    By Green Hulk in forum 4-Tec Performance
    Replies: 42
    Last Post: 01-02-2006, 09:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •