Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 28
  1. #1
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28

    15/22r pump nose cone

    Hey guys, just changed my prop to the Solas 15/22r. Just as i had it all back together and on the ski, i looked up to see a flash new green pump nose cone (the one that threads on) sitting on my ski in its packet .
    I reused the nose cone off of my stock prop not realising i got a new one with the 15/22r. Is this going to be an issue? please say no

    Thanks in advance


  2. #2
    richrxp's Avatar
    Join Date
    Jun 2006
    Location
    Netherlands
    Posts
    949
    +1
    1
    There have been problems reported,using the oem plastic cone.
    I would use the green metal one,and make sure it's tight.
    The plastic ones travel on the driveshaft, and cause a leaking carbon driveshaft seal.






    Quote Originally Posted by monaroman76 View Post
    Hey guys, just changed my prop to the Solas 15/22r. Just as i had it all back together and on the ski, i looked up to see a flash new green pump nose cone (the one that threads on) sitting on my ski in its packet .
    I reused the nose cone off of my stock prop not realising i got a new one with the 15/22r. Is this going to be an issue? please say no

    Thanks in advance

  3. #3
    Quote Originally Posted by richrxp View Post
    There have been problems reported,using the oem plastic cone.
    I would use the green metal one,and make sure it's tight.
    The plastic ones travel on the driveshaft, and cause a leaking carbon driveshaft seal.
    The Metal ones (or any Nose Cone for that matter) will have the same problem if not very tightly installed. I found that using some gasket sealant on the threads, wrapping the Cone with some protective matl. and tighening w/ a spanner would get it tight enough to stay put.. Some people dont use any Cone at all with no ill effects... Just FYI if you dont already know, the Cones have left-handed threads. If yours is damaged, I have a new one I'll sell.

  4. #4
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    Every time I have ever fitted that green nose cone it has come loose and walked up the shaft causing cavitation and a loss of top end.

    I only ever run the stock nose cone now with some polyurathane sealent on the threads, it never come loose that way. Make sure you do it up real tight. There might be a few 10th of a MPH in the cone but you will see much bigger differences in speed from water conditions and weather.

    I would most definately not be removing my pump again to fitt the green metal cone. R88

  5. #5
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,263
    +1
    474
    Good prop and yes the oem boot works fine ..

    Did you loose any rpm with that prop??

  6. #6
    richrxp's Avatar
    Join Date
    Jun 2006
    Location
    Netherlands
    Posts
    949
    +1
    1
    I'm running without the cone for two years now,no problems at all.
    I have done this on salt water also, doesn't matter a thing.
    Don't have to worry about loose nosecones anymore.
    People say you may see slight speed gains from removing the cone,i can't confirm this because i did this with a lot of other mods at the same time..




    Quote Originally Posted by richrxp View Post
    There have been problems reported,using the oem plastic cone.
    I would use the green metal one,and make sure it's tight.
    The plastic ones travel on the driveshaft, and cause a leaking carbon driveshaft seal.

  7. #7
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    6,359
    +1
    975
    I installed a Speedfreeks nose cone on a Solas 15/22R using red locktite on the threads of the nose cone and the threads of the impeller. I simply screwed the nose cone into the impeller by hand......and it hasn't moved at all.

  8. #8
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by 1tommygunner1927 View Post
    I installed a Speedfreeks nose cone on a Solas 15/22R using red locktite on the threads of the nose cone and the threads of the impeller. I simply screwed the nose cone into the impeller by hand......and it hasn't moved at all.
    +1 No problems with my Speedfreaks cone.

    I never have put the stock cone back on, but I have used the Solas ones, and they have walked up the shaft.

  9. #9
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Quote Originally Posted by troyheb View Post
    +1 No problems with my Speedfreaks cone.

    I never have put the stock cone back on, but I have used the Solas ones, and they have walked up the shaft.
    Thanks for all the replies guys. Looks like i wont be pulling it apart to switch the cones over.
    My only worry now is... Did i do the bloody thing up tight enough

  10. #10
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Quote Originally Posted by richrxp View Post
    There have been problems reported,using the oem plastic cone.
    I would use the green metal one,and make sure it's tight.
    The plastic ones travel on the driveshaft, and cause a leaking carbon driveshaft seal.

    Hey Rich i just went out for a test ride. Everything was all sweet, for 20 minutes or so when i noticed the ski seemed a little sluggish. On lifting the seat to inspect i noticed that the hull was about 1/3 filled with water. I quickly got it back on the trailer and drained the hull. There was A LOT of water in there.
    Have i damaged the carbon seal whilst installing the new prop? could the nose cone be the issue?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SOLD 09 SD Pump with SOLAS 15/20 impeller, R&D Nose cone
    By jp1300r in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 09-04-2015, 07:05 PM
  2. FS SRZ 15/22R with speed freaks nose cone
    By ATNryan in forum Sea Doo Classifieds
    Replies: 11
    Last Post: 07-27-2014, 06:51 AM
  3. SOLD 951 155mm jet pump nose cone
    By ncdoo in forum Sea Doo 2 Stroke Skis
    Replies: 0
    Last Post: 08-02-2013, 08:55 PM
  4. help with pump nose cone
    By homebrew in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-28-2010, 09:51 PM
  5. 04 RXP pump nose cone removal
    By fcs1965 in forum 4-Tec Performance
    Replies: 14
    Last Post: 03-09-2009, 06:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •