Results 1 to 9 of 9
  1. #1
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28

    Boost leak through throttle body lube

    Hey guys just curious about something. My yellow cap that connects to the black hose that runs to the throttle body wasn't sitting on the hose, it must have been worn and was popping off. Is this boost leak significant enough to affect performance?


  2. #2
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    i took mine off completely and installed a vacumn cap over it..

  3. #3
    home of the dislexic fingers breon's Avatar
    Join Date
    Aug 2007
    Location
    port st lucie fl
    Posts
    3,471
    yep they do that small zip tie

  4. #4
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    +1 I used a small zip tie to hold it on.

  5. #5
    Banned User
    Join Date
    Sep 2009
    Location
    Aussie Land
    Posts
    804
    +1
    21
    + 3

    Now using a vacuum cap.

  6. #6
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Quote Originally Posted by lolzer View Post
    + 3

    Now using a vacuum cap.
    I went with the ghetto fix. Screw in the vacuum line. I have a new yellow cap on order though. So this would have been affecting my performance slightly maybe?

  7. #7
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Ghetto fix!! Nice!!
    Your only getting 72.8 with an XX and a 15/22R? Doesn't seem right?

  8. #8
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Nar bro, that was before them mods. Haven't had a chance to test since the upgrades..

  9. #9
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Ok now that I read it again it makes sense. I neglected to see the + . Sorry about that. I forget that it is coming into riding season for you guys unlike us up here.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. STX-15f Fogging through Throttle Body
    By NJParty in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 10-04-2015, 07:54 PM
  2. Throttle body lube?
    By tornado34 in forum 4-Tec Performance
    Replies: 9
    Last Post: 06-20-2014, 04:48 PM
  3. Throttle body lube
    By Jonno in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 05-04-2010, 03:03 PM
  4. 06RXP Throttle body lubing
    By Summer in forum 4-Tec Performance
    Replies: 11
    Last Post: 04-26-2010, 12:32 PM
  5. throttle body lube cap popping off ??
    By Kaybat in forum 4-Tec Performance
    Replies: 9
    Last Post: 04-23-2010, 11:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •