Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23

Thread: Bailer tubes

  1. #1
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28

    Bailer tubes

    Hey guys, where one of my bailer tubes goes into the yellow 90 I have a leak. There is a hole in it which I believe is meant to be there but that's where it's coming out. Why's this happening? Did I do something wrong when I put the pump back on? I've noticed both my drain plugs are dodgy aswell, I have to poke a screw driver into them to get them to drain after I take the plugs out..


  2. #2
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Ahh well, strangely enough i went for a ride and accidentally left the plugs out, the hull was completely dry after the ride..

  3. #3
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Miami, FL
    Posts
    2,419
    +1
    10
    Invest in a bilge pump, you will thank me later.

  4. #4
    Booner76's Avatar
    Join Date
    Oct 2009
    Location
    Stirling ,Ont.
    Posts
    222
    +1
    5
    Quote Originally Posted by ImAShark View Post
    Invest in a bilge pump, you will thank me later.
    +1 on that!

  5. #5
    home of the dislexic fingers breon's Avatar
    Join Date
    Aug 2007
    Location
    port st lucie fl
    Posts
    3,471
    i installed builge pumps after the bailer tube check valves started sticking..and it fill up with water..i replace the the check valves they were cheap and then installed 2 ?750 bilge pumps...

  6. #6
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    So I need to replace the check valves breon?

  7. #7
    thedirtyburd's Avatar
    Join Date
    Jun 2010
    Location
    Ann Arbor, MI
    Posts
    75
    Check to see if the siphon tubes are in the venturi, if one or both is missing then that is your problem.

  8. #8
    h2jim's Avatar
    Join Date
    Nov 2008
    Location
    Ontario Canada
    Posts
    2,063
    +1
    61
    +1 on the syphon tubes. I installed a new adjustable venturi on mine that I bought from a forum member. He had the syphon holes filled so I drilled them out. I nearly sunk the ski the next day because I didn't have the syphon tubes in the venturi. I had no idea what they did but now I do for sure.

  9. #9
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Sorry I'm not quite understanding what you mean, can you give me a pic? I put the 83mm nozzle on and replaced the zip ties that hold the bailer tubes onto the connections under the vts unit with hose clamps.. Is that what you mean by the syphon tubes?
    Cheers

  10. #10
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Siphon tubes are in the venturi.
    I doubt that's your issue, there hard to come out.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bailer Tubes
    By HankC350 in forum 4-Tec Performance
    Replies: 13
    Last Post: 08-06-2014, 11:45 AM
  2. Bailer tubes
    By Green Hulk in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 11-22-2008, 08:33 AM
  3. Bailer Tubes/zip ties?
    By barefoot1 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 01-14-2008, 03:15 PM
  4. Mud wasps in my bailer tubes!
    By WildBill9000 in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 05-22-2006, 05:48 AM
  5. 2 questions (coolant tube and bailer tubes)
    By mickey78 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 07-21-2005, 01:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •