Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 32
  1. #1
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3

    Stage 3 FZR Problems

    This FZR has a Riva Stage 3 with an R3 (Minus VIPEC) and Riva Waterbox and it flys (85+ GPS)

    I have 2 issues that I have learnt to live with for the past 50 hours.

    1) GIO - the oil level rises on the stick about 1 mm for every tank of gas. AFRs are 11 - 11.5 according to my LC-1

    2) Vibration that comes on between 3000-4500 RPM when acclerating slowly or uhooking in this range. 5000RPM - 8300RPM is as smooth as silk.

    I have changed the BOV, E1 wheel, Prop, SC Clutch (New Version) and even swapped SC with friend that runs a C5 drop-in wheel with no luck. (The C5 ran smooth on his FZS but vibrated slightly on mine)

    I am confused as to how this ski hauls ass (50hours) and has these issues. I am tired of changing the oil every 5 tanks.

    I believe the vibration is boost related as the stock wheel does not vibrate, almost like I need 2 BOVs. Riva says my problem is internal (Harmonic) but I am not convinced.

    Help needed.


  2. #2

    Join Date
    Mar 2010
    Location
    the moon
    Posts
    862
    +1
    19
    Silly question but have you checked your prop and output shaft etc...

  3. #3
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3
    Quote Originally Posted by razzie View Post
    Silly question but have you checked your prop and output shaft etc...
    No question is silly !!

    The driveshaft is perfect, but why would the output shaft be bad if there is no vibration on the stock wheel?

    I also have the upgraded Riva S/C shaft and bearings.

  4. #4
    305coco's Avatar
    Join Date
    May 2007
    Location
    cape coral, florida USA
    Posts
    2,363
    +1
    55
    on the GIO issue, you are using riva's cooling kit? and is your T-stat in?

  5. #5
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3
    Using Riva Cooling Kit with the thermostat in, also have a ball valve with the oil filter reading approx 195F (Infrared Thermometer) after some long WOT runs. Our water temp stays between 83-87F year round.

  6. #6
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,591
    +1
    4,797
    Antiguan, stop whining. With all that beautiful water and those bikinis running around you there, I really don't feel too sorry for you having to change your dang oil every 5 tanks.

  7. #7

    Join Date
    Oct 2007
    Location
    Brisbane, Australia
    Posts
    1,538
    +1
    3
    Quote Originally Posted by Antiguan FZR View Post
    2) Vibration that comes on between 3000-4500 RPM when acclerating slowly or uhooking in this range. 5000RPM - 8300RPM is as smooth as silk..
    Change yar plugs.

  8. #8
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3
    Quote Originally Posted by YoYamma View Post
    Antiguan, stop whining. With all that beautiful water and those bikinis running around you there, I really don't feel too sorry for you having to change your dang oil every 5 tanks.
    Man, I want my yami to be smooth jus like de butter-skin gals.

  9. #9
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3
    Quote Originally Posted by Gunna View Post
    Change yar plugs.
    Did that and same result.

  10. #10
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3
    Do the E1/HKS bov equiped fzrs have any vibration when the bov releases boost?

    We don't have any other set-ups like mine to compare.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FZR Riva Stage 3 Build + problems
    By pearny in forum Yamaha PWC Performance (4-stroke)
    Replies: 54
    Last Post: 07-10-2013, 03:26 PM
  2. FZR Riva Stage 3 Build + problems
    By pearny in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 06-20-2013, 01:58 PM
  3. 2005 GTX SC Stage I w/ problems
    By jpeconsult in forum 4-Tec Performance
    Replies: 79
    Last Post: 01-18-2008, 04:57 PM
  4. Replies: 9
    Last Post: 04-19-2006, 07:06 PM
  5. riva stage 1 kit problems
    By macattack in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-28-2005, 05:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •