Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    mike2's Avatar
    Join Date
    Sep 2010
    Location
    San Angelo, TX
    Posts
    79

    piston ring question

    I purchased a set of used 1050 cylinders and pistons that I am using to replace the bad cyliders in my 700 virage. I also purchased a set of new rings for a 700 part#2200902 . I just noticed for a 1050 the part#2200918. Now I think the part numbers interchange but the problem I have is when I try to put the bottom ring on it wont compress down into the groove, not even half way in. Should i get a groove cleaner and try that or does anyone have any advise? thanks


  2. #2
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    So you bored the 700 domestic engine out to the stock 1050 bore ?

  3. #3

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    Quote Originally Posted by seaobin View Post
    So you bored the 700 domestic engine out to the stock 1050 bore ?
    there the same bore 81mm

  4. #4
    rlharrison60's Avatar
    Join Date
    Aug 2007
    Location
    Orange, Texas
    Posts
    1,091
    +1
    1
    Do have the ring gap ligned up with the stop in the ring wall?

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,574
    +1
    1,272
    Quote Originally Posted by rlharrison60 View Post
    Do have the ring gap lined up with the stop in the ring wall?
    Is the piston ring or piston groove keystone shaped (tapered) on one side?

    Piston rings with a non-square cross-section must be installed right side up



  6. #6
    PolarisNut's Avatar
    Join Date
    Dec 2006
    Location
    Lower Michigan
    Posts
    1,809
    Like K said, its probably upside down. There should be a "dot" or logo on the top side of the ring.

  7. #7
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,570
    +1
    34
    Are you using Polaris pistons ? I think it was "bgaiden" that found the Polaris ring are different than WSM rings.A picture should help.

  8. #8
    mike2's Avatar
    Join Date
    Sep 2010
    Location
    San Angelo, TX
    Posts
    79
    Here are some pictures. I have already installed the pistons. It is hard to tell in the pictures but they have 80,88 and 1 also AUS with the arrow printed on them. The rings have a faint E printed on them. I was tying to put them in with the E facing up. I will go backout and try them with the E facing down and see if that works. Click image for larger version. 

Name:	IMG00106-20101208-1213.jpg 
Views:	69 
Size:	57.3 KB 
ID:	223425Click image for larger version. 

Name:	IMG00107-20101208-1214.jpg 
Views:	67 
Size:	76.5 KB 
ID:	223424Click image for larger version. 

Name:	IMG00105-20101208-1213.jpg 
Views:	64 
Size:	138.1 KB 
ID:	223423

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,574
    +1
    1,272
    Quote Originally Posted by mike2 View Post
    ...the problem I have is when I try to put the bottom ring on it wont compress down into the groove, not even half way in...
    Quote Originally Posted by mike2 View Post
    ...I have already installed the pistons...
    How did you install the piston if the ring wouldn't seat into the piston groove?

    Do you mean the pistons are on the connecting rods, but the cylinders have not been installed over the pistons?

  10. #10
    mike2's Avatar
    Join Date
    Sep 2010
    Location
    San Angelo, TX
    Posts
    79
    no cylinders they are just on the connecting rods.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Carb 951 piston ring question
    By kingbryce in forum 2-Stroke Performance
    Replies: 7
    Last Post: 01-04-2016, 10:29 PM
  2. 2002 Virage 700 Piston/Ring Question
    By Johnnycyclone in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 06-08-2012, 09:19 PM
  3. Piston ring installation question.
    By SniperSR71 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 06-17-2011, 09:37 AM
  4. Piston and rings question
    By My95GTX in forum 2-Stroke Performance
    Replies: 6
    Last Post: 06-09-2009, 05:01 PM
  5. Quick question about piston rings
    By xltrider in forum Yamaha How To & FAQs
    Replies: 5
    Last Post: 05-14-2007, 02:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •