Page 1 of 8 1 2 3 ... LastLast
Results 1 to 10 of 74

Thread: 99 SLTH Rebuild

  1. #1
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324

    99 SLTH Rebuild

    I just recently got a 99 SLTH with a blown engine. I am right now acquiring parts and almost have everything I need. Its pretty much going to be a stock rebuild, with the exception of a few bolt ons. The hull looks great, no fading, and just a few small nicks and scrapes. So far I have a 6 vein stainless stator to add to it. I have also decided to add trim, and eventually an Ocean Pro ride plate. I picked up a brand new Polaris crank on ebay for 200 bucks. And I got a WSM top end rebuild kit for Christmas. I also found an ignition update kit to add. I just need to get my cylinders machined. Im having them done .5mm oversize. Luckily the jet pump is in perfect condition, no nicks on the impeller and .008 to .010 clearance, with no damage to the extension ring. I need to replace the grey fuel lines.. MFD works perfectly. So by the time its done, I should have a beautiful ski with a brand new engine for around $1200. I will post pics in a bit. This is going to be for my wife to ride, when she goes with me, but if I go alone with my friends on Lake Michigan I will be riding it too.

    Click image for larger version. 

Name:	IMG_0453.jpg 
Views:	68 
Size:	80.5 KB 
ID:	225457Click image for larger version. 

Name:	IMG_0451.jpg 
Views:	75 
Size:	80.9 KB 
ID:	225458Click image for larger version. 

Name:	IMG_0452.jpg 
Views:	80 
Size:	131.8 KB 
ID:	225459
    Last edited by Mr. Matrix; 01-04-2011 at 10:53 AM. Reason: Added pics


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Just installed the updated CDI and ignition coil...... Also assembled the jet pump nozzle that now includes trim and reverse!!!!! Now to get the trim motor and the control switch and I will be all set with that..

  3. #3
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Here are some pics of the engine carnage. It looks as if the bottom rod bearing on the PTO failed and melted the bottom of the rod. Previous owner says his kid was pulling 2 tubes behind the ski for a few hours and thats what blew it up.

    Click image for larger version. 

Name:	IMG_0455.jpg 
Views:	76 
Size:	91.9 KB 
ID:	225460Click image for larger version. 

Name:	IMG_0457.jpg 
Views:	91 
Size:	78.0 KB 
ID:	225461Click image for larger version. 

Name:	IMG_0454.jpg 
Views:	83 
Size:	114.1 KB 
ID:	225462Click image for larger version. 

Name:	IMG_0456.jpg 
Views:	83 
Size:	49.5 KB 
ID:	225463

  4. #4

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    Quote Originally Posted by BryanP View Post
    Here are some pics of the engine carnage. It looks as if the bottom rod bearing on the PTO failed and melted the bottom of the rod. Previous owner says his kid was pulling 2 tubes behind the ski for a few hours and thats what blew it up.

    Click image for larger version. 

Name:	IMG_0455.jpg 
Views:	76 
Size:	91.9 KB 
ID:	225460Click image for larger version. 

Name:	IMG_0457.jpg 
Views:	91 
Size:	78.0 KB 
ID:	225461Click image for larger version. 

Name:	IMG_0454.jpg 
Views:	83 
Size:	114.1 KB 
ID:	225462Click image for larger version. 

Name:	IMG_0456.jpg 
Views:	83 
Size:	49.5 KB 
ID:	225463
    OUCH !!!!

  5. #5
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    I do have a brand new Polaris crank here and will be paying a visit to Mr Zigler next week to get the rest of what I need.

  6. #6
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Well first off, I want to thank John Zigler. I took my cylinders to him and he had them bored and honed, and they came out looking great. I got my engine assembled and did my leak down test. I ended up using a little sealer on the reed cages and intake manifold, they would not seal up at all with the rubber gaskets that were on them. Is that pretty common? After finding the leaks and pumping it up to 10 PSI, I have only lost about 1/4 PSI over 20 minutes. All I need to do is mount the updated stator, flywheel and flywheel cover and its ready to drop back in. Now to find some help to do it..........

  7. #7
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Engine is now in........just need to hook up electrical and waterbox and Im going to fire it up tomorrow.

  8. #8
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Got it all installed and wired up. Did all new fuel lines. Added some premix to the tank and it fired right up as soon as the gas hit the carbs. All I have left is the trim motor, engine alignment and to fix a few small nicks in the gel coat and this baby will be perfect.

    Click image for larger version. 

Name:	IMG_0459.jpg 
Views:	59 
Size:	67.3 KB 
ID:	226425Click image for larger version. 

Name:	IMG_0460.jpg 
Views:	73 
Size:	71.5 KB 
ID:	226424Click image for larger version. 

Name:	IMG_0461.jpg 
Views:	68 
Size:	86.6 KB 
ID:	226426Click image for larger version. 

Name:	IMG_0458.jpg 
Views:	75 
Size:	92.0 KB 
ID:	226427

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Very nicely done

    Have you considered changing the seat to the touring type? It has sculpted humps for front and the rear riders. Changes the overall look of the PWC too.

    Rather rare, but they do pop up from time to time.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Polaris SLT Touring seat cropped (ph2ocraft).jpg 
Views:	112 
Size:	17.8 KB 
ID:	226444  

  10. #10

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    Looks good !!!!!!!!!!

Page 1 of 8 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. '99 slth running hot - hellp needed.. =)
    By fr33man in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 06-16-2008, 11:51 AM
  2. 99 SLTH running lousy
    By Hammy129 in forum Polaris How To & FAQs
    Replies: 12
    Last Post: 08-02-2007, 10:30 AM
  3. Checking Static timing 99 slth 700
    By bski224 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-02-2007, 06:07 PM
  4. How to check Stator 99 SLTH
    By bski224 in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 05-30-2007, 03:07 PM
  5. 99 SLTH Wiring Diagram
    By ph2ocraft in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 10-22-2006, 06:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •