Results 1 to 10 of 10
  1. #1

    1994 Polaris SL650 No Spark

    Good Evening
    New to the Jet Ski World,short story,got a great deal on a sl650 last year with a hole in one piston,dissasembled the jugs replaced all 3,new rings etc. The jet ski ran great for a week,no Spark,put away till now,I had been snooping around this sight and found you guys very informative and helpful to people,I have done the preliminary checks Stator checks out at:
    Red/White to Green/Red 466 ohms
    Blue/Red to Red/White 82.7 ohms
    White/Yellow to Black 211 Ohms
    Red/Purple to Yellow .6 Ohms

    The spark plug wire caps are with in spec as well as the secondary side of the coils,When I check the primary side black and White to Black I get .3 ohms on all the coils,I even checked another set and they were the same,The CDI box is a new Polaris one. Also it has a brand new start stop switch and tether
    What am I missing!!!!!!!!!!!!!!!!!!!!!!!!!!!

    Any help would be appreciated,


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Welcome to the Hulk cammo.

    What year ski do you have?

    First, is the lanyard installed?

    Second, is the circuit breaker tripped at the top of the elec box if so equipped?

    Next, have tried bypassing the kill switch all together? NOTE: choke the engine until it dies if it does start, or if it ever runs away from you. (we call this the death rev)

    You mentioned a new CDI. What year CDI and what model is it for?

    Have you checked the ground wire connection at the engine plate? Make sure it's clean and tight.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Welcome to the Hulk

    If you have not already, check out the links in my signature

  4. #4

    No Spark

    Forgot about the year,it is a 1994,the breaker is not tripped,I actually made a jumper for the stop start switch and used that in place of the tether. I don't have a the number off the top of my head but the cdi box is for a 1994 sl650,I understand about the digital vs. analog,I will check the ground today.

  5. #5
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Sounds like you're pretty well informed.

    Check out the links in K447 signature and follow the troubleshooting chart.

  6. #6
    First I would like to thank you guys for the help,the jet ski is alive,I believe K447 had put up a post about disconnecting the black/yellow wire from the cdi box and check for spark. That was the issue,lesson learned,when I made the loop to jump the start stop switch that actually grounds it out to shut it off,lesson learned and with the new switch and lanyard installed and wired it starts and runs fine even shuts off with the button and the lanyard.time for winterizing and now it can get out of my shop for the winter.

    Any input on a 2004 MSX150 turbo,it needs a engine rebuild but the price doesn't seem to bad (950.00)

    Once again thanks and if I can help anyone with any transmission related issues give me a shout,have a small shop here in CT.

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Quote Originally Posted by cammotorsports View Post
    First I would like to thank you guys for the help, the jet ski is alive...

    Any input on a 2004 MSX150 turbo? It needs a engine rebuild but the price doesn't seem to bad (950.00)

    Once again thanks and if I can help anyone with any transmission related issues give me a shout, have a small shop here in CT.
    Glad to hear you got the SL650 sorted out

    Regarding the MSX 150 - the actual internal condition of that Weber engine is critical to determining the value. Rebuilding a Weber engine can get expensive very easily.

    If there is any signs of flaking metal or metal particles inside the cylinders then the cylinder Nicasil lining has failed, and the engine will need rebuilding and the cylinders replated. Weber engine work tends to involve a lot of labor.

    Often the initial diagnosis of the Weber engine can be inaccurate, especially if the person doing the diagnosis is unfamiliar with these Weber engines.

    Click my signature links to read up on some common issues that affect Weber engines, such as sticking turbo wastegate.

    You are welcome to post up the name and location of your Transmission shop. You never know whether there are other Greenhulk members nearby, even if they don't own a Poalris PWC

  8. #8

    Spark

    The last question about the polaris,I would like to replace the wire set,any suggestions?

    The msx-150 I know has a compression issue,one of the 2 cylinders is good and the other one has only about 10 P.S.I

  9. #9
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Wires are glued into the coils. Best thing to do is cut the wires back about 1/4" to expose fresh wire and resecure the plug boots back on. (as long as they spec out)

  10. #10
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Welcome to the Hulk..

    Tell your town to plow the ramp. LOL. And breaking the ice would be a bonus.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 polaris virage no spark, HELP!
    By robmeyer in forum Polaris Open Discussion
    Replies: 25
    Last Post: 06-12-2017, 12:29 PM
  2. 94 Polaris SL650 No spark
    By ChopperPilot08 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-06-2008, 06:37 PM
  3. Polaris 800DI no spark
    By Bear in forum Polaris Open Discussion
    Replies: 16
    Last Post: 05-09-2008, 05:34 AM
  4. 2002 polaris virage no spark
    By maples32 in forum Polaris Open Discussion
    Replies: 12
    Last Post: 03-13-2008, 09:43 PM
  5. 2001 polaris virage no spark & no fuel
    By paintballer89 in forum Polaris How To & FAQs
    Replies: 15
    Last Post: 05-01-2007, 07:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •