Results 1 to 4 of 4
  1. #1
    driveumhard's Avatar
    Join Date
    Feb 2007
    Location
    Cape Copral, FL
    Posts
    1,475
    +1
    4

    2009 RXT iS taking on water

    Any 09 iS owners having issues with water in the hull? It seems like after each time I ride about 1/2 gallon of water comes out when I unscrew the drain plugs. Shouldn't the bilge pump kick on? Hoses seem tight but it's so damn hard checking down in there with all the plastic. Anyone have a clue?

    Thank you!
    Last edited by driveumhard; 12-31-2010 at 02:55 PM. Reason: sp


  2. #2
    Full Throttle or Broke!!! UNSANE's Avatar
    Join Date
    Aug 2008
    Location
    Orlando
    Posts
    721
    +1
    82
    Is the water hot or cold? I'm actually on my second ski, my first one only lasted minutes as there was a leak somewhere in the raw water path (think an exhaust seal was the problem), but this problem was so bad, my ski only worked for about 20 minutes before she started to suck steam into its intake and she went into limp mode. The dealer gave me a new ski and now I barely get a squirt after pulling the plugs, even after ocean riding/jumping.

    PS: Are you in Florida now? There's a ride for tomorrow in St Pete.

  3. #3
    do you reverse alot?

  4. #4
    driveumhard's Avatar
    Join Date
    Feb 2007
    Location
    Cape Copral, FL
    Posts
    1,475
    +1
    4
    The water is warm but not hot & always salt. This ski never used to take on any water. I just started to notice the water issue around 50 hours (68 hours on ski now).Use reverse only when backing off the trailer. May have to go back to the dealer.

    I'm back north now. Enjoy the ride in St Pete!

    Quote Originally Posted by UNSANE View Post
    Is the water hot or cold? I'm actually on my second ski, my first one only lasted minutes as there was a leak somewhere in the raw water path (think an exhaust seal was the problem), but this problem was so bad, my ski only worked for about 20 minutes before she started to suck steam into its intake and she went into limp mode. The dealer gave me a new ski and now I barely get a squirt after pulling the plugs, even after ocean riding/jumping.

    PS: Are you in Florida now? There's a ride for tomorrow in St Pete.
    Last edited by driveumhard; 01-01-2011 at 10:50 AM. Reason: sp

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXT Is taking on water?
    By normann in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-25-2011, 05:33 PM
  2. my 780 slt is taking on water
    By hawg in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-19-2009, 05:50 PM
  3. So this guy's GPR is taking on water
    By Pistonwash in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 04-17-2009, 06:46 PM
  4. RXT-X taking on water after mods !
    By Alfy in forum 4-Tec Performance
    Replies: 30
    Last Post: 09-04-2008, 03:03 PM
  5. 97 spx is taking on water. Any suggestions???
    By dleary46 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 08-02-2008, 10:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •