Results 1 to 2 of 2

Thread: need help

  1. #1

    need help

    hello i have a polaris jet ski virage 800 direct inject
    been trying to fix
    need help
    cranks over but wont start
    cranks for about 30 to 45 seconds
    then sounds like shot gun blast out exhaust
    tried multiple times does the same
    had brain rebuilt and
    tested in another ski and works
    put back in mine and it does the same
    any info would be nice
    wondering if anyone has had same problem

  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    near Toronto, Canada
    Welcome to the Hulk

    Who rebuilt the EMM module?
    Did the EMM actually have a problem that was repaired, or was it simply checked/updated?

    Your problem description sounds like an EMM problem, but it could be a stator or flywheel problem. Or possibly the CPS sensor or LR Start/Stop module.

    Do you still have access to another fuel injected two cylinder Virage i to swap parts between?

    Are the correct NGK PZFR6H spark plugs installed?

    Does the MFI display 'wake up' immediately when you crank the engine for the first time after it has been sitting quietly for more than five minutes?

    How long have you had this machine?
    Has it ever worked properly for you?
    What is the service/repair history?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts