Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12

Thread: Help me

  1. #1

    Help me

    Hello everybody, after completely overhauled my engine still have a big problem. My engine is a 2005 and can confirm Jerry as I put all new parts, my problem is this, after replacing the entire engine, but I put 5lt oil after it sparked my dipstick oil does not signal anything , all the oil remains inside the pto speeds up to about 5000rpm and when you turn on the written chek engine, the only thing that I have not changed and the piston valve oil pressure regulator. Please given me more info for my problem resolution. really thanks to all who help me. hello


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    If you put in 5 liters of oil it's extremely over filled.
    3.7 quarts should be all you need.

    You will need to remove some oil.

    To properly check your oil level the engine must be hot. Let the engine idle for 30 seconds, shut it off and wait 30 seconds, check the oil.

  3. #3

    oil

    Quote Originally Posted by Green Hulk View Post
    If you put in 5 liters of oil it's extremely over filled.
    3.7 quarts should be all you need.

    You will need to remove some oil.

    To properly check your oil level the engine must be hot. Let the engine idle for 30 seconds, shut it off and wait 30 seconds, check the oil.
    Dear Jerry , on 2005 if engine is very clean (inside) is 5.2lt , see manual, i have different problem, My oil remains inside the PTO, today i remove oil pressure switc Today I removed the sensor switches on the front oil pump and oil does not come out, After I removed the pump and the oil that was inside the PTO came all out of the canal that connects the front with pto pump, So if the oil pump comes in front dinuovo please send the oil in the crankcase? I think I burn everything. also failing oil pressure sensor oil pump in front when i turn my engine light comes on at 5000rpm ceck engine. Hello Jerry help me all the new parts of the installation that you sent me. hello

  4. #4

    visit my post

    Quote Originally Posted by samui View Post
    Dear Jerry , on 2005 if engine is very clean (inside) is 5.2lt , see manual, i have different problem, My oil remains inside the PTO, today i remove oil pressure switc Today I removed the sensor switches on the front oil pump and oil does not come out, After I removed the pump and the oil that was inside the PTO came all out of the canal that connects the front with pto pump, So if the oil pump comes in front dinuovo please send the oil in the crankcase? I think I burn everything. also failing oil pressure sensor oil pump in front when i turn my engine light comes on at 5000rpm ceck engine. Hello Jerry help me all the new parts of the installation that you sent me. hello
    140 people have viewed my post, but no one can give me some advice?

  5. #5
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    I dont understand you

  6. #6
    sorry for my english, i have this problem: i installation all new parts on my engine , 2 oil pumps,gasket,recondition head all parts, bearing and more, OK? i put inside 5lt oil OK?, and yesterday i start my engine and after few minuts i control oil level OK?, i don't have oil on my stick OK?, i remove s.c. and exit more oil from hole OK? i have all oil in pto cover OK?, today i remove oil pressure switc in front pump and start my engine i don't exit oil OK?, after i remove oil pump and when is removed come out oil this arrive by from the pipeline that starts from the PTO and outside hull exsit 3.5 lt oil OK? in this case this line is perfect OK?, where is problem? now you understand ? very thanks ciao.OK??????

  7. #7
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    If the oil pressure regulator is scored/stuck would this stop oil from going to the front oil pump? It would be worth replacing this I think; it is located on the bottom of the PTO cover on the rear of the engine. My oil pressure regulator was worn/scored and got sticky and was giving me oil pressure alarms anytime rpms went over 5000 rpm too. Replaced the oil pressure regulator assembly (spring, sleeve, small piston, cost maybe $60?) and it was fine.

    This also reminds me of a post quite awhile ago where Shibby was having this problem and it was driving him crazy too ... not sure of the post or if he ever determined the cause. If I find the post I will post a link.

  8. #8
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128

  9. #9
    thanks man, you speak the valve serves to regulate the pressure of this oil should be open when we have an over pressure, if I remember correctly opens at 5 psi? i can not remember if this value is correct, I can change this test tomorrow volvulus but not the problem. hello thanks for your help.

  10. #10
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    I think you are correct ... it starts closed normally so pressure can build, but as pressure gets too high, it opens to avoid over-pressurizing the engine. But it often gets crushed on reassembly of the motor due to overtightening. When that happens it can cause major oil pressure problems and must be replaced. It might not be your problem, but it is one possibility worth checking out.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Guys with UMI set ups... Help me out. Please.
    By Water4fire in forum 4-Tec Performance
    Replies: 31
    Last Post: 05-06-2006, 02:17 PM
  2. Can someone help me resize this animated gif?
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 04-06-2006, 09:38 PM
  3. Can anyone help me with my impeller shaft and new prop?
    By ccassone in forum 2-Stroke Performance
    Replies: 0
    Last Post: 02-10-2006, 03:45 PM
  4. GP 1200 carburator on Venture 1100 help me?
    By dre23 in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 11-22-2005, 12:39 AM
  5. 05 rxp or 00-03 xp? help me decide.
    By djburkeen in forum Sea Doo Open Discussion
    Replies: 23
    Last Post: 06-06-2005, 12:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •