Results 1 to 7 of 7
  1. #1
    2000 GPRXP 4tec shooter98xpl's Avatar
    Join Date
    Dec 2005
    Location
    Charleston SC
    Posts
    2,717
    +1
    3

    05 Flywheel bolts

    So I picked up a gasket and flywheel bolts from Jerry to replace the ones just to make sure I don't end up having them back out. So I took all the bolts off the cover and when I tried pulling the cover off, it only comes out 1/2" and seems like something is holding it. Am I missing something on getting the cover off? I figured it would have just pulled right off, but its not. I got the SC and the water pump off the cover, so what am I missing?
    SHOOTER


  2. #2

    Join Date
    May 2005
    Location
    Minneapolis
    Posts
    763
    +1
    26
    It's probably just the magnets in the mag holding it to the flywheel - it has some good pull.

    Good luck

  3. #3
    Gotta love this sport! 05Limited's Avatar
    Join Date
    Apr 2005
    Location
    Stockton, CA
    Posts
    2,677
    +1
    4
    If the engine is in the ski then you have to remove the left, aft motor mount for the cover to come off.

  4. #4
    b_dolla44's Avatar
    Join Date
    Apr 2008
    Location
    Noblesville, Indiana United States
    Posts
    1,165
    +1
    15
    Also there is a bolt behind the T stat that needs to be removed....

  5. #5
    I have also had the front of the bendix get stuck in the pto cover.

  6. #6

    Join Date
    May 2005
    Location
    Minneapolis
    Posts
    763
    +1
    26
    Watch your shims on the bendix also

  7. #7
    2000 GPRXP 4tec shooter98xpl's Avatar
    Join Date
    Dec 2005
    Location
    Charleston SC
    Posts
    2,717
    +1
    3
    Motor was out of the ski, I finally had figured it out. I thought it was the bendix stuck in the housing as well, but it wasn't. It was the freaking bracket. Got that off and whalla, cover came off. Fortunately the shims stayed on the starter drive. But starter drive moved, so that was a lot of fun getting back together and back in its spot. Shims were simple, they are springs shims so faced them together, washer on the outside to go up against the outer housing, Its all put back together and updated flywheel bolts torqued down and new gasket installed. X charger installed. I did notice that the previous owner had already tapped the oil hole which I know some of you guys plug up but I left it unplugged. Next thing to do, install the depth finder and gauges on the gprxp and set the motor back in. Let you guys know how that goes, thanks for the help and advice, should have come back on here and looked but I was determine to figure it out.
    SHOOTER

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 11-22-2014, 12:48 PM
  2. 05 rxp flywheel bolt replacement question
    By PWC Newbie in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 05-29-2011, 08:09 PM
  3. replacement of flywheel bolts (03-05)
    By masta2000 in forum 4-Tec Performance
    Replies: 19
    Last Post: 05-17-2010, 11:45 AM
  4. Tip of the day: flywheel bolts on 03-05 models
    By Green Hulk in forum Sea Doo How To & FAQs
    Replies: 37
    Last Post: 12-28-2007, 09:49 AM
  5. Flywheel bolts
    By gerhand44 in forum Polaris How To & FAQs
    Replies: 21
    Last Post: 11-08-2006, 01:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •