Results 1 to 5 of 5
  1. #1

    Join Date
    Jun 2009
    Location
    Tierra Verde, Florida, United States
    Posts
    911
    +1
    17

    NEED HELP!! Had motor out of RXT and now everything is dead?

    I need help!!! I can't figure out what is going on. I had the motor out of 05 RXT and now it's dead will not do anything. The dress key doesn't beep (nothing) it's like the battery is not there.
    The battery is fully charged.
    All 3 of the grounds are bolted to the motor.
    All the fuses on the MPEM are good.
    What am I missing I know it has to be something stupid?
    Thanks


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Do you have the starter and battery + switched?

  3. #3
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    check for continuity (if you have a multimeter) from any metal part on the engine to the negative battery post

  4. #4

    Join Date
    Jun 2009
    Location
    Tierra Verde, Florida, United States
    Posts
    911
    +1
    17
    Quote Originally Posted by ultramaxracing05 View Post
    check for continuity (if you have a multimeter) from any metal part on the engine to the negative battery post
    check out good.

  5. #5
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    Quote Originally Posted by beerdart View Post
    Do you have the starter and battery + switched?
    had that happen to me...the battery I bought had the charges switched. positive was marked negative and negative was marked positive...talk about an expensive oops!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 95 sl 650 sludge blowing out of intake and outlet... What is it?
    By FlynRyn79 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 09-27-2013, 01:16 PM
  2. Replies: 6
    Last Post: 08-15-2013, 10:06 AM
  3. Need help on pulling motor out of 08 gp1300r???
    By ZIGGY18 in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 08-05-2010, 05:03 PM
  4. Easiest wasy to testing trim motor out of ski? Some help
    By TMPLUMBER59 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 07-31-2009, 07:18 AM
  5. First day out of the season....now she is sick :-(
    By hyoctane23 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 06-18-2007, 09:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •