Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1

    Join Date
    Jun 2009
    Location
    Tierra Verde, Florida, United States
    Posts
    911
    +1
    17

    Thumbs up looking for HELP!!! on RXT Electrical problem....dead

    I need help!!! I can't figure out what is going on. I had the motor out of 05 RXT put it back in and now it's dead, will not do anything. The dress key doesn't beep (nothing) it's like the battery is not there.
    The battery is fully charged.
    All 3 of the grounds are bolted to the motor.
    All the fuses on the MPEM are good.
    What am I missing I know it has to be something stupid?


  2. #2
    eb87's Avatar
    Join Date
    May 2010
    Location
    South East Coast
    Posts
    566
    +1
    25
    I wish you were a bit closer than St. Pete.... beautiful area to ride btw!
    Double check everything is my best advice. Do you have the maintenance manual? I can give you a copy if you'd like. Lots of good info in it. I am going thru the manual right now as I try to learn about seadoo.

    Sorry I can't be anymore help.

  3. #3

    Join Date
    Jun 2009
    Location
    Tierra Verde, Florida, United States
    Posts
    911
    +1
    17
    Quote Originally Posted by eb87 View Post
    I wish you were a bit closer than St. Pete.... beautiful area to ride btw!
    Double check everything is my best advice. Do you have the maintenance manual? I can give you a copy if you'd like. Lots of good info in it. I am going thru the manual right now as I try to learn about seadoo.

    Sorry I can't be anymore help.
    Thanks, I do have a manual...just not helping me yet.

  4. #4
    First try another battery to make sure it is not the culprit.

  5. #5

    Join Date
    Jun 2009
    Location
    Tierra Verde, Florida, United States
    Posts
    911
    +1
    17
    Quote Originally Posted by 8 is enough View Post
    First try another battery to make sure it is not the culprit.
    I tried that..

  6. #6
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Quote Originally Posted by joewharton2 View Post
    I tried that..
    check the 2 small red wires comming off the large red batt cable by the solenoid for an open

  7. #7
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Quote Originally Posted by WFO View Post
    check the 2 small red wires comming off the large red batt cable by the solenoid for an open
    or could be a bad dess post

  8. #8

    Join Date
    Jun 2009
    Location
    Tierra Verde, Florida, United States
    Posts
    911
    +1
    17
    Quote Originally Posted by WFO View Post
    check the 2 small red wires comming off the large red batt cable by the solenoid for an open
    I looked at that 2 or 3 times...all good.

  9. #9

    Join Date
    Jun 2009
    Location
    Tierra Verde, Florida, United States
    Posts
    911
    +1
    17
    Quote Originally Posted by WFO View Post
    or could be a bad dess post
    I haven't check it but I really don't think it's that

  10. #10
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Quote Originally Posted by joewharton2 View Post
    I haven't check it but I really don't think it's that
    I have (2) 06 RXTs here now and one has a dess post that went bad while the boat was here being worked on...

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Video: Looking for help on 2008 RXT-X 255
    By Ski Hacks MG in forum 4-Tec Performance
    Replies: 27
    Last Post: 06-07-2016, 09:26 AM
  2. looking for help on 2002 polairs genesis
    By travisingram29 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-10-2010, 11:12 AM
  3. Looking for help on a 1200xlt
    By sfackett0 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 03-28-2009, 12:47 AM
  4. Newbi looking for help on purchase of Speedster 150
    By mstewart in forum Sea Doo Sport Boats
    Replies: 19
    Last Post: 12-16-2007, 10:54 AM
  5. Replies: 3
    Last Post: 09-21-2007, 11:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •