Results 1 to 9 of 9
  1. #1

    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    194

    2000 XL limited won't go above idle

    hi evryone,
    I just picked up a 2000 yamaha XL limited as a winter project. I was told by the previous owner that it runs fine on the trailer, but when it goes in the water it only does like 5 mph. All I have done so far was to check compression. The first cylinder has about 110 psi, the middle and PTO cylinder have like 130 psi. I was told that it got a new crank recently and new cat. and a new cylinder. The ski has 121 hours. I am hoping that it is just a sensor or something.
    I am wondering where I should start. I now a little about waverunners, but I am no expert.
    From what I have read I will be getting a D-plate, wave eater clips and going pre-mix.
    Thanks is advance for any help I get on fixing up this ski.


  2. #2

    Join Date
    Jul 2008
    Location
    cape cod
    Posts
    195
    if it was me i would take a look at the carbs

  3. #3
    could be anything from fuel lines to throttle lines. Could be ignition issue. not likely but...if the compression is good you can fix it.

  4. #4

    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    194
    Does anyone know where I can download a free PDF service manual for this ski. Thanks for the advice.

  5. #5
    i got one off this sit i think. it is the factory yami manual. do a search and you will find it.

  6. #6
    Waveruiner pauladave's Avatar
    Join Date
    Mar 2007
    Location
    Clayton le Woods, North West England,UK.
    Posts
    409
    PM me and I'll send you the manual and parts book for the XL1200 Ltd. Does the engine rev up and the ski still only does 5mph? I'd be looking at pump/driveline etc. if that's the case. If the engine doesn't rev, then carbs and electrics may need a check. Cheers, Dave.

  7. #7
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    Does it rev up in the water but only goes 5 mph?

  8. #8

    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    194
    I am finally getting a look at this ski, I hope to know whether it will rev up soon.

  9. #9

    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    194
    Well this project is done. I have it all back together again. I had the carbs rebuilt by onside Bill (Thanks Bill) and I installed a D-plate and wave-eater clips and coverted the ski to pre-mix. The ski runs great now. It has a top speed on GPS at 57mph, is that what it should be? I also noticed that the throttle at low speeds is a little choppy. It sometimes almost feels like a "on" or "off" kinda thing. Not real smooth.
    Another thing that I have noticed is that I have to let it idle for a little bit on start-up or increase the throttle slowly or it wants to stall. After 20 to 30 seconds slow ramp up or coming on and off the throttle it is fine. Thoughts?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 GSX won't rev above idle
    By crazeejames in forum 2-Stroke Performance
    Replies: 111
    Last Post: 09-09-2011, 07:22 PM
  2. 2000 genesis ficht wont rev up above idle please help!!
    By rspray in forum Polaris Open Discussion
    Replies: 7
    Last Post: 08-11-2010, 02:03 PM
  3. 2000 XL1200 Limited Won't Run
    By H2Otx in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 08-31-2009, 10:16 AM
  4. 2000 xl 1200 won't run help??
    By bode1 in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 07-03-2008, 12:36 AM
  5. 2002 GTX DI won't run above idle in water
    By zone 5 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-26-2007, 06:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •