Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1
    maxadrenaline's Avatar
    Join Date
    Nov 2007
    Location
    RETIRED !! In Mobile AL or Wherever I Want To Go
    Posts
    1,414
    +1
    137

    BOV Stuck and Leaking Boost ?

    I had a good test run planned and wanted to post this in case it happens to someone else. I installed the ET SS wheel (low boost) and was all excited about testing it. Nice weather, 64 and water was 58.
    First ran AFR's and all good. I was rich in mid range before the ET wheel, and after ET wheel it leaned out great. 11.5 in mid, a little lean on top end, 12.3 WOT 8420rpms.
    I decided to do a back to back with the R&D vs Riva SS grate. Put in the R&D grate, ran out and wtf,,,only 7920 rpms. Ok,,that is wierd...back to the dock put the Riva back in and 7650 rpms...uh oh.....checked the wheel, clutch, hoses,,clamps all was good. Put the LM2 back in and AFR's were crazy rich on top end and lean about 7k. Played with that a while and noticed the BOV did not whistle like it used to..
    Back to the dock,,,on the trailer I could feel air coming from the BOV with just a little blip of the throttle,,about 2k rpms...
    Has this happened to anyone else ? BTW,,,JD IC and his BOV.
    I now have to figure out a way to install a flange mount Greddy on my JD IC. I wanted to do that anyway..just not yet...lol
    Chuck


  2. #2
    gordon lasiter #328's Avatar
    Join Date
    Aug 2008
    Location
    katy, texas , United States
    Posts
    1,647
    +1
    28
    that was one of the mods i had done this winter.....
    you can get a aluminuim flange for about $25.00.
    the ssqv has its limitations.

  3. #3
    I would have liked to see the diff between the [email protected] and the riva stainless grates. Have you used them both?

  4. #4
    maxadrenaline's Avatar
    Join Date
    Nov 2007
    Location
    RETIRED !! In Mobile AL or Wherever I Want To Go
    Posts
    1,414
    +1
    137
    Do you remember where you got the flange and how does it adapt to the JD IC?
    Thanks,
    Chuck

  5. #5
    maxadrenaline's Avatar
    Join Date
    Nov 2007
    Location
    RETIRED !! In Mobile AL or Wherever I Want To Go
    Posts
    1,414
    +1
    137
    I was in the process of doing a back to back when the BOV quit on me. As soon as I get that fixed, I will do another test.


    Quote Originally Posted by miker1 View Post
    I would have liked to see the diff between the [email protected] and the riva stainless grates. Have you used them both?

  6. #6
    I had an [email protected] on my Fx and riva on my Fz and it felt like the Fx accelerated harder.

  7. #7
    305coco's Avatar
    Join Date
    May 2007
    Location
    cape coral, florida USA
    Posts
    2,362
    +1
    55
    chuck my buddy had a similar problem with his ssqv, it was sticking open, we sprayed some lube oil in it and problem went away..

    interested in your back 2 back test on the grates..

  8. #8
    lets race.... mikeFZR's Avatar
    Join Date
    Mar 2009
    Location
    MA
    Posts
    4,132
    +1
    205
    I just cleaned my HKS SSQV yesterday. I know JD doesnt use genuine HKS but the process of cleaning it and preventing it from sticking should be similar. Here's the directions I used...
    How-To: Take apart and clean HKS SSQV

  9. #9
    maxadrenaline's Avatar
    Join Date
    Nov 2007
    Location
    RETIRED !! In Mobile AL or Wherever I Want To Go
    Posts
    1,414
    +1
    137
    Thanks Jorge, I will try that.


    Thanks Mike, Good write up and photos on that one...that BOV was UGLY..I hate to fight that snap ring again,,,Grrrrr

  10. #10
    305coco's Avatar
    Join Date
    May 2007
    Location
    cape coral, florida USA
    Posts
    2,362
    +1
    55
    if it ever happens again ill take it apart and clean it inside. but this time we didnt take it off i just pushed it open with my finger and sprayed the lube oil in it. i was told NOT to use wd-40

    also guys that ride in salt water can lube them often cause the salt deposit can build up around the rubber seal and not seal properly,

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. BOV controversy and confusion
    By UnleashedBeast in forum 4-Tec Performance
    Replies: 21
    Last Post: 06-08-2007, 09:59 PM
  2. tunnel reinforcement and leak problem
    By Tiplickhahaha in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-29-2006, 07:24 AM
  3. OPAS Block-Off's and Leaking
    By mbriddle in forum 4-Tec Performance
    Replies: 18
    Last Post: 06-20-2006, 11:58 PM
  4. got my Dynotune wideband F/A and digital boost gauge today.
    By rapidacceleration in forum 4-Tec Performance
    Replies: 7
    Last Post: 03-24-2006, 05:18 PM
  5. Installed BOV today, and SC Clutch took a crap....
    By 05RXPnoob in forum 4-Tec Performance
    Replies: 37
    Last Post: 08-14-2005, 10:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •