Results 1 to 9 of 9
  1. #1

    broken ficht injector bolts

    I have a machine in my shop with the ficht fuel injection system on it. it has one of the bolts that holds the injector to the head broken off. it is on the PTO cylinder. i was curious if any body here has seen this problem and determined the cause of this. i have heard of other people in other forums having exactly the same problem, but never has any body come up with a explanation of why.

    i was referred to this site from somebody on one of the other sites. any help is appreciated.

    thanks


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Hey XS WELCOME to the Green Hulk forums!!!

    I'd replace ALL of the mounting bolts, chase the threads to make sure nothing is hanging you up and giving you a fasle torque reading. I'm sure you are torqueing the bolts, correct?
    It was also suggested you make sure the injectors are not cracked and to make sure the O rings are under the injectors.
    Jay also told me if you over-tighten those injectors you can wind up distorting the spray pattern. It's good way to burn down an engine!!

    Good Luck and let us know what happens!

  3. #3
    Bernie's Avatar
    Join Date
    Aug 2006
    Location
    Perth Australia
    Posts
    902
    +1
    1
    xcsnowman,If the bolt was overtightened or more probably when the bolt was inserted the threads in the head had salt crust in it .The bolts will break .Best to drill it out heicoil it if your drill wanders and use some antiseize when you put it together.Make sure you pull the injector down evenly .

    Cheers

    Bernie

  4. #4
    Moderator boataddict's Avatar
    Join Date
    Apr 2005
    Location
    Ottawa, Ontario, Canada
    Posts
    3,822
    +1
    39
    I snapped an injector stud on my MSX. We replaced all of them and torqued them with a new calibrated Snap On torque wrench and it happened again. I think there is a flaw there.

  5. #5
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Quote Originally Posted by BOATADDICT View Post
    I snapped an injector stud on my MSX. We replaced all of them and torqued them with a new calibrated Snap On torque wrench and it happened again. I think there is a flaw there.
    But did you chase the threads and replace the injector seals?
    I talked to several Polaris dealers today and they all told me the same thing.........no issues.
    I wish we could talk to one of the claims adjusters at Polaris Industries and see what they say.

  6. #6
    Moderator boataddict's Avatar
    Join Date
    Apr 2005
    Location
    Ottawa, Ontario, Canada
    Posts
    3,822
    +1
    39
    We chased the threads but did not replace the seals.
    The 03 I had is a timebomb. It consistantly breaks down.

  7. #7
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    I know that feeling!! My 03 still haunts me to this day.
    I do know the first run 03's were troublesome.

  8. #8
    Bernie's Avatar
    Join Date
    Aug 2006
    Location
    Perth Australia
    Posts
    902
    +1
    1
    Craft ,
    When it comes to the injected ski's .It doesnt matter how lightly you polish a turd .It still gets all over your fingers

    Cheers
    .
    Bernie

  9. #9
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    LOL Hi Bernie!! Great to see you, I owe you a Skype call.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How to remove a broken engine mount bolt? Virage TXi FRC hull
    By K447 in forum Polaris Open Discussion
    Replies: 20
    Last Post: 07-21-2016, 07:24 PM
  2. Broken motor mount bolt
    By roost5o in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 06-04-2008, 01:56 PM
  3. The ficht injector
    By Bernie in forum Polaris Open Discussion
    Replies: 3
    Last Post: 01-13-2008, 04:17 PM
  4. Broken trim tab bolt; help!!
    By jpa1300 in forum Yamaha PWC Performance (2-stroke)
    Replies: 17
    Last Post: 07-31-2007, 07:29 PM
  5. Help-Broken bow eye bolt (Repair)
    By Duke in forum Yamaha PWC Performance (2-stroke)
    Replies: 13
    Last Post: 02-23-2007, 09:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •