Results 1 to 2 of 2
  1. #1

    Join Date
    Jan 2011
    Salt Lake City, UTAH

    Polaris engine mount question?

    1998 SLXH 1050
    I just pulled/lifted my engine to replace the stator with the new upgrate, in doing so, one of the engine mount metal studs separated from the rubber bushing? Strange to me! It seems that the flat metal welded to the bolt/stud was somehow fused to the rubber bushing, but nothing else holding the mount solid? As I look at it, the design seems flawed, in that I cannot see what holds the actual mount together?
    Has anyone dealt with this? Can I Glue/ or fuse the metal back to the rubber?
    Or is best to purchase a new complete engine mount?

    Any help would be appreciated!

  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    near Toronto, Canada
    Well, a new 3021254 engine mount (replacement part # for the original 3110055) runs almost $60.

    I would suggest calling John Zigler, see what he has on hand. His contact info can be found through my signature links, under Parts Sources

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. front engine mount
    By oklagp1200r in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-24-2008, 04:24 PM
  2. 96 XP front engine mount
    By Madjamr in forum 2-Stroke Performance
    Replies: 2
    Last Post: 09-14-2007, 09:09 AM
  3. Rotax HD Engine Mount
    By Sirhc7897 in forum 4-Tec Performance
    Replies: 13
    Last Post: 03-26-2006, 07:48 PM
  4. RR Front Engine mount
    By terryt in forum 4-Tec Performance
    Replies: 3
    Last Post: 02-28-2006, 10:28 AM
  5. RR Engine Mount
    By Kinchyle in forum 4-Tec Performance
    Replies: 6
    Last Post: 02-18-2006, 04:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts