Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
  1. #1
    Everthing louder than everything else! sHALlow's Avatar
    Join Date
    Jun 2010
    Location
    Panama City, FL
    Posts
    391
    +1
    27

    XS IC help. What am i doin wrong?

    Just now getting around to my XS IC install on my 06 RXT. this is JFiz's updated version, the directions haven't been updated to address the new specs. Do i have the right couplers/pipes where they need to be? i have tried all combinations and i either end up short on one side or the pipes dont meet up right in Click image for larger version. 

Name:	DSC08191.jpg 
Views:	82 
Size:	87.0 KB 
ID:	228909the couplers and they bow out causing a pinch in the coupler. i know this would cause a boost leak for sure. I have the 3 standoffs on the bottom loosClick image for larger version. 

Name:	DSC08193.jpg 
Views:	132 
Size:	111.5 KB 
ID:	228908e and the bungees aren't connected so i am able to move the IC in all directions allowed by the mounting plate. any input for me? Thanks for the help.Click image for larger version. 

Name:	DSC08192.jpg 
Views:	87 
Size:	86.7 KB 
ID:	228907


  2. #2
    cjo632racing's Avatar
    Join Date
    Sep 2008
    Location
    Ocala Fl.
    Posts
    191
    +1
    3
    looks like the 4" air intake is getting in the way? I am putting the same thing in my 06 rxt no problem, but my 4" air intake runs along the top of the valve cover.

  3. #3
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001
    Yeeeap, nightmare to get right. It seldom appears to be exactly right, but as long as the hoses are sealed all around, it will fit.... and it really works too.

    Many glass fibres in the forearms will be a product to enjoy later!!!

  4. #4
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Couplers/pipes can be setup that way, but not for sure on how Fizzle set the kit up. Try swapping 45 pipe/st coupler with 45 coupler/St pipe.
    If you can bring ic closer to motor should fit in pipe from ic to TB.

  5. #5
    Everthing louder than everything else! sHALlow's Avatar
    Join Date
    Jun 2010
    Location
    Panama City, FL
    Posts
    391
    +1
    27
    Quote Originally Posted by cjo632racing View Post
    looks like the 4" air intake is getting in the way? I am putting the same thing in my 06 rxt no problem, but my 4" air intake runs along the top of the valve cover.
    Nah. its not the kanaflex. defintly not making the job any easier but not restricting movement of the pipe/couplers/IC.

  6. #6
    Everthing louder than everything else! sHALlow's Avatar
    Join Date
    Jun 2010
    Location
    Panama City, FL
    Posts
    391
    +1
    27
    Quote Originally Posted by skoepp View Post
    Couplers/pipes can be setup that way, but not for sure on how Fizzle set the kit up. Try swapping 45 pipe/st coupler with 45 coupler/St pipe.
    If you can bring ic closer to motor should fit in pipe from ic to TB.

    It actually fits worse the other way. the 45 pipe and straight couplers end up way short. i was trying to pull the IC closer but the 45 pipe hits the SC flange. so are you saying its ok for the couplers to be pinched? no boost leaks if the clamp is tight?

  7. #7
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    You don't want it pinched if possible.
    Not saying to do this until someone confirms preferred install, but if you shorten the 45 pipe on both ends it will make it possible to bring ic closer on ic to TB.
    Mine is like that and the pipe is very short on both pipes.
    I don't have fizzle bracket tho.

  8. #8
    Everthing louder than everything else! sHALlow's Avatar
    Join Date
    Jun 2010
    Location
    Panama City, FL
    Posts
    391
    +1
    27
    im starting to work it. i ended up extending the straight pipe so i could put it further in the 45 coupler. it allowed me to finagle the other pipe and couplers. trick now is to tighten clamps in the sweet spot so they dont pinch. thanks for the help with this and yes RichieB im wearing a long sleeved sweathshirt to avoid the arm itch.

  9. #9
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    807
    Shallow, I'm really sorry that I forgot to forward the new instructions. Your picture below is the correct way. Turn the coupler on the throttle body so that the opening is facing down. Turn the coupler on intercooler so that the opening is facing up. Pull the intercooler forward a little bit if there's not enough pipe to get a good clamp down. It might also come together easier if you can manage to turn the intercooler more towards the supercharger/exhaust side of the ski.

    Quote Originally Posted by sHALlow View Post
    Just now getting around to my XS IC install on my 06 RXT. this is JFiz's updated version, the directions haven't been updated to address the new specs. Do i have the right couplers/pipes where they need to be? i have tried all combinations and i either end up short on one side or the pipes dont meet up right in the couplers and they bow out causing a pinch in the coupler. i know this would cause a boost leak for sure. I have the 3 standoffs on the bottom loosClick image for larger version. 

Name:	DSC08193.jpg 
Views:	132 
Size:	111.5 KB 
ID:	228908e and the bungees aren't connected so i am able to move the IC in all directions allowed by the mounting plate. any input for me? Thanks for the help.
    Sorry, the pic didn't come through again. The 2nd picture in your original post.

  10. #10
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    807
    Here's an updated document (big file)

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What am I doing wrong, top end on gp1200r seems... Slow
    By xxkinetikxx in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 09-23-2013, 10:23 PM
  2. What am i doing wrong or do i need??
    By 97modman in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 09-18-2011, 07:54 AM
  3. What am i doing wrong?
    By skewman in forum Yamaha PWC Performance (4-stroke)
    Replies: 10
    Last Post: 07-18-2010, 11:18 AM
  4. HELP! What did I do WRONG
    By problown89gt in forum Polaris Open Discussion
    Replies: 6
    Last Post: 07-01-2009, 09:56 AM
  5. Help on XS IC
    By ivylion13 in forum 4-Tec Performance
    Replies: 10
    Last Post: 02-28-2008, 05:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •