Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1

    250 ultra running rich

    I have a Ultra 250x 2008 119kph on gps which I purchased new for $21500 on a trailer about 70hrs on it never really missed a beat with until now, I had the pulleys changed and pop off blocking plate installed for more boost, intercooler and 2010 impeller shaft mod done , when the work was done the jet-ski shop could only get 3 spark plugs out and the fourth rear one stuck in the head they said it would probably would snap off and as I was on holidays and 20hr's from home I took the ski away, now after riding the ski would sometimes hesitate when hard on the throttle from idle which seem to be getting worst the more I ride it, so in to the shop close to home for service and new plugs, which one snapped off damit off with the head now all back together but it's still running rough at idle and really rich, blowing black smoke what would be causing this? anyone had this happen to them? Cheers and thank you for you help


  2. #2
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,157
    +1
    598
    Quote Originally Posted by big-m2003 View Post
    I have a Ultra 250x 2008 119kph on gps which I purchased new for $21500 on a trailer about 70hrs on it never really missed a beat with until now, I had the pulleys changed and pop off blocking plate installed for more boost, intercooler and 2010 impeller shaft mod done , when the work was done the jet-ski shop could only get 3 spark plugs out and the fourth rear one stuck in the head they said it would probably would snap off and as I was on holidays and 20hr's from home I took the ski away, now after riding the ski would sometimes hesitate when hard on the throttle from idle which seem to be getting worst the more I ride it, so in to the shop close to home for service and new plugs, which one snapped off damit off with the head now all back together but it's still running rough at idle and really rich, blowing black smoke what would be causing this? anyone had this happen to them? Cheers and thank you for you help
    my money is that the MAP sensor isnt plugged in or the Vacum line is off

    The sensor is just infront of the Throttlebody on the head side of the butterfly

    Waz
    ps what rpm are u doing at those sppeds ?

  3. #3
    If any electronic sensor is unplugged or not sensing the usual value, there should be red "FI" light flashing on your dashmeter. No "FI" light means most likely not a sensor related issue.

    Pull out the spark plugs (again) and check their color. Post pics here if possible. It could be a mechancal issue that sensor can't detect.

    BTW, shouldn't the 2nd shop take a look at this problem since they are the once who worked on your ski the last time?

  4. #4
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    thats a fast ski

  5. #5

    Join Date
    Dec 2009
    Location
    SE Asia
    Posts
    370
    +1
    3
    Quote Originally Posted by nicjak View Post
    thats a fast ski
    Yes... I agree.. .since I run the same ski!

  6. #6
    Fat Man, Little Boat Region8Ultra250X's Avatar
    Join Date
    Jun 2007
    Location
    Jersey
    Posts
    5,563
    +1
    169
    73 mph with just pulleys, intercooler and the BOV blockoff?

  7. #7
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    nah it has more boost and a 2010 prop shaft

    Quote Originally Posted by Region8Ultra250X View Post
    73 mph with just pulleys, intercooler and the BOV blockoff?

  8. #8
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,157
    +1
    598
    Quote Originally Posted by sirbreaksalot View Post
    my money is that the MAP sensor isnt plugged in or the Vacum line is off

    The sensor is just infront of the Throttlebody on the head side of the butterfly

    Waz
    ps what rpm are u doing at those sppeds ?
    MMMMMMMMMMMMM what RPM

    That will tell the story.................cause you need GOOD RPM on a stock prop to get even close to those posted numbers

  9. #9
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,157
    +1
    598
    3 mph current ..................

  10. #10
    Offshore Aussie's Avatar
    Join Date
    Jan 2010
    Location
    South East Australia
    Posts
    548
    119km please explain? If possible could you list all mods, many of us don't see even close to that with more. I'm tipping current advantage as well. Bloody fast dude, and you rekon it's rich?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FX HO or Ultra 250 / Ultra LX - which to buy ?
    By B58FURY in forum Kawasaki PWC Performance (4-stroke)
    Replies: 29
    Last Post: 06-11-2008, 07:35 AM
  2. FX HO or Ultra 250 / Ultra LX - which to buy ?
    By B58FURY in forum Yamaha Open Discussion
    Replies: 3
    Last Post: 07-20-2007, 02:35 PM
  3. FX HO or Ultra 250 / Ultra LX - which to buy ?
    By B58FURY in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-18-2007, 07:16 AM
  4. FX HO or Ultra 250 / Ultra LX - which to buy ?
    By B58FURY in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 06-17-2007, 09:21 PM
  5. running rich?
    By shhr in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-02-2007, 10:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •