Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Post Low performance in 2004 GTX Wake Edition

    Hi, I bought a Sea Doo 4-TEC GTX Wake Edition (2004), to start practicing wakeboard, but Ive realized that the watercraft is not having enough performance over 6000RPM to allow somebody to stand up with the wakeboard. The ring and impeller are almost new, but still the watercraft is not having a good low performance. Somebody know how to solve this issue not very costly. Im thinking to buy a R&D Performer Kit for 155 HP Naturally Aspirated Sea Doo, but i do not know if this could work. As well Im thinking to buy another impeller to give more power to the watercraft to allow doing wakeboard not suffering so much to stand up. Please!!! Somebody could help me? Im living in Mexico, and here there is not good information and no good mechanics to solve this issues. Thanks!!!!
    Last edited by GustavoDF; 02-15-2011 at 07:11 PM.


  2. #2
    eb87's Avatar
    Join Date
    May 2010
    Location
    South East Coast
    Posts
    566
    +1
    25
    Welcome to Green Hulk Gustavo. I'll do my best to help.

    Que es el problema? las revoluciones no pasan de 6000? o el motor acelera pero la maquina no quiere moverse?

  3. #3
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by eb87 View Post
    Welcome to Green Hulk Gustavo. I'll do my best to help.

    Que es el problema? las revoluciones no pasan de 6000? o el motor acelera pero la maquina no quiere moverse?
    Guys, if you can keep the questions in English then there will be alot more people on here that will be able to help out...Thanks

    Now my question is, does your skis RPMs go above 6000 or no??

  4. #4
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    +++1 snowman

  5. #5
    eb87's Avatar
    Join Date
    May 2010
    Location
    South East Coast
    Posts
    566
    +1
    25
    Quote Originally Posted by Snoman View Post
    Guys, if you can keep the questions in English then there will be alot more people on here that will be able to help out...
    Good idea I was just trying the help the man out in his native language...and I wanted to practice

  6. #6
    La maquina acelera muy bien hasta las 8000 revoluciones, pero cuando pasas de las 6000 revoluciones la maquina no se mueve al momento de salir, una vez que el PWC empieza a acelerar responde bien. El problema es el impulso inicial cuando quieres hacer wakeboard y necesitan mas fuerza para jalar alguien fuera del agua, y es all donde la maquina no responde bien (como si la helice cavitara).Gracias por tu ayuda!!!!!!

  7. #7
    Thanks for your interest to help!!!!!! (My english is not so good, but Ill do my best!!)
    The skis goes perfectly above 6000, but when is over that RPM at the moment of start up, and you have somedoby trying to stand up doing wakeboard, the machine is not having power enoght to do it. But, once that the skis is over 15 MPH and you acelerate over 6000 RPMs the response is very good.

  8. #8
    eb87's Avatar
    Join Date
    May 2010
    Location
    South East Coast
    Posts
    566
    +1
    25
    Sounds like you have cavitation, based on previous information here it is most likely caused by:

    A bad wear ring
    A bad carbon seal
    or the impeller front cone backing out

    First check the nose cone on the impeller cone to see if its fully seated, then look at the wear ring, if those are good most likely is the carbon seal.

  9. #9
    eb87's Avatar
    Join Date
    May 2010
    Location
    South East Coast
    Posts
    566
    +1
    25
    Now let me see how I can translate this...

    Suena come el problema es cavitacion, segun informacion aqui, probablemente el problema es:

    El aro de plastico en la helice
    El sello de carbon
    o el aro al frente de la helice se aflojo y salio de su lugar.

    Primero inspecciona el aro al frente de la helice, despues el aro de plastico, si no es el sello de carbon. Dajame saber si necesitas mas ayuda.

  10. #10
    Thank you very much for that tips. I'll check them and let you know. You are completely right about cavitation. Thats what is happening when you are acelerating above 6000 RPMs. The problem is not in the wear ring because it is new( it was the first spare part i change but the problem was not solved). Now i'll check the impeller and the carbon ring. If there is no problem on that i'll post it here. Thanks again. Do you know if the performance kit for the 4tec 155hp works fine to improve the performance of the skis?
    Pd. Your spanish is really very good!! Congrats!!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 09-06-2012, 11:02 PM
  2. 2004 Sea Doo GTX Wake edition fuel consumption
    By HKT Boy in forum 4-Tec Performance
    Replies: 19
    Last Post: 03-18-2012, 04:45 PM
  3. 2004 GTX wakeboard edition, not supercharged
    By rmaier4425 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 08-15-2010, 04:37 PM
  4. Replies: 2
    Last Post: 03-20-2009, 09:51 AM
  5. 2006 RXT Seat fit in 2004 GTX SC?
    By guduf4u in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 08-22-2007, 07:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •