Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23

Thread: Antifreeze leak

  1. #1
    TIMBA27's Avatar
    Join Date
    Feb 2011
    Location
    Miami
    Posts
    12

    Antifreeze leak

    Hi guys on this forum,this is my 1 post here..i have a 2008 SD 215 with stage 1 plus SC impeller,oil catch can,riva waterbox,SC blow of kit,heavy duty cluth washers...the engine have 38 hr,i got it brand new from a dealer in miami,always has been take care and service as well...my problem here is the ski have antifreeze leak and don't know were is it...even the "MECHANIC" in the dealer in miami..they did pressure test and all thing you guys can inmagine and nothing found,the ski run very good...73 mph 8300 rpm...but after 2 or 3 hr running the antifreeze is gone,that's been happened the 3 or 4 times i was in the water,i been look in every places on the machine but nothing found...if any one can help me it will very appreciate or any one with the same problem...thanks


  2. #2
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    It could possibly be your headgasket.. To diagnose this, take your ski for a few WOT runs with the seat off and the overflow tube directed into the footwell. If your HG is blown your cooling system will become pressurized and blow the coolant out the overflow.
    I wouldn't think this was likely at that low of hours, but if a pressure test didn't detect a leak, it's quite possible. My HG gave out before 100 hours.

  3. #3
    5.0. alex_baker202's Avatar
    Join Date
    Aug 2007
    Location
    Lebanon, Missouri, United States
    Posts
    1,027
    +1
    24
    Mine was doing the same thing. I would guess you do not have the screw type hose clamps where the coolant runs into your ride plate and back out. I took mine to
    The dealer 4 times before I finally figured it out after reading online. Id also check that the plastic that is glued into the hull where the hose attaches is also not broke.

  4. #4
    TIMBA27's Avatar
    Join Date
    Feb 2011
    Location
    Miami
    Posts
    12
    well today i screw all the hoses from the thermostat to the ride plate,some was a little weak i noticed...tomorrow i will go to the lake to see what happen...took mine to the dealer more than 3 times i was all last summer with the ski in the dealer...4 months...BTW thanks for reply guys

  5. #5
    TIMBA27's Avatar
    Join Date
    Feb 2011
    Location
    Miami
    Posts
    12
    In case the issue is the headgasket how much will cost?

  6. #6
    TIMBA27's Avatar
    Join Date
    Feb 2011
    Location
    Miami
    Posts
    12
    I forgot to tell the mechanic looked for water in the engine oil and nothing found so he said is not the headgasket...

  7. #7
    Swedish Viking Craigo's Avatar
    Join Date
    Jun 2008
    Location
    Seattle
    Posts
    1,367
    +1
    62
    Quote Originally Posted by TIMBA27 View Post
    I forgot to tell the mechanic looked for water in the engine oil and nothing found so he said is not the headgasket...
    Don't believe what shop mechanics tell you! IMO they are a bunch of idiots! Do a search for "leaking head gasket" here in the 4tec performance section read ALL of the posts - and you'll discover that your "mechanic" doesn't know shit.

  8. #8
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Quote Originally Posted by Craigo View Post
    Don't believe what shop mechanics tell you! IMO they are a bunch of idiots! Do a search for "leaking head gasket" here in the 4tec performance section read ALL of the posts - and you'll discover that your "mechanic" doesn't know shit.
    +1, typically the HG blows out between the cylinder and the water jacket. Meaning there would not be coolant in your oil. Be sure to do the test I advised and you will know for sure. I went for about 3 WOT runs before any coolant puked out the overflow, and the HG was the cause. This may not be your problem, but elimiating it will get you one step closer to finding the cause. also When you put your ski back on the trailer, leave it running and have a good look around the ride plate for a leak.

    If your HG is blown, the OEM gasket will cost you about $80. Head bolts are around $70. I don't know the cost of the labour as I did it myself.
    Good luck, post back with your findings.

  9. #9
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Quote Originally Posted by monaroman76 View Post
    +1, typically the HG blows out between the cylinder and the water jacket. Meaning there would not be coolant in your oil. Be sure to do the test I advised and you will know for sure. I went for about 3 WOT runs before any coolant puked out the overflow, and the HG was the cause. This may not be your problem, but elimiating it will get you one step closer to finding the cause. also When you put your ski back on the trailer, leave it running and have a good look around the ride plate for a leak.

    If your HG is blown, the OEM gasket will cost you about $80. Head bolts are around $70. I don't know the cost of the labour as I did it myself.
    Good luck, post back with your findings.
    +2 if your mechanic told you that he has limited knowledge of 4Tec engines. They typically only express failure signs at WOT and pressure forces the coolant out the overflow. Your oil will look fine. Its easy to diagnose as monarmon said. Just watch the overflow at WOT. Have you had any hi temp alarms yet? If so be careful not to warp your head.

  10. #10
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    it also could be leaking ride plate bolts, is there coolant in the engine bay?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Antifreeze leak
    By frogurt in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 04-15-2012, 08:14 PM
  2. Antifreeze leaks
    By race24x in forum 4-Tec Performance
    Replies: 15
    Last Post: 09-09-2010, 04:55 PM
  3. 2009 RXT-X Antifreeze leak(looks like rideplate)
    By GP1300R in forum 4-Tec Performance
    Replies: 15
    Last Post: 09-01-2009, 02:44 PM
  4. 2006 gti se antifreeze leak
    By icerat4 in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-06-2008, 05:04 PM
  5. antifreeze leak or overheat?
    By North49 in forum 4-Tec Performance
    Replies: 25
    Last Post: 10-17-2006, 07:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •