Results 1 to 4 of 4
  1. #1

    Melted SHO Resonator

    Stock 2009 SHO. Melted resonator blown off hose attachment. Waterlock too hot to touch. Tons of smoke billowing from rear hull area. Any ideas as to cause? No mods. No indicators or warnings on dash. Anyone had this happen before? Thanks, Mel


  2. #2
    305coco's Avatar
    Join Date
    May 2007
    Location
    cape coral, florida USA
    Posts
    2,363
    +1
    55
    make sure the cooling system is flowing water correctly, for example you could have have sucked up some sand starting the ski on the beach and clogged the cooling passages and overheated the waterbox causing the resonator to melt.. just a thought.

  3. #3
    abracadabra's Avatar
    Join Date
    Oct 2008
    Location
    Wellington, FL United States of America
    Posts
    2,046
    +1
    180
    Quote Originally Posted by meleho808 View Post
    Stock 2009 SHO. Melted resonator blown off hose attachment. Waterlock too hot to touch. Tons of smoke billowing from rear hull area. Any ideas as to cause? No mods. No indicators or warnings on dash. Anyone had this happen before? Thanks, Mel
    Man, that is crazy. Usually there is enough water flowing through the exhaust system. Good time to upgrade to the RIVA rear exhaust tho. I installed mine last night and the installation is super easy, Julio...

  4. #4
    Thanks for the reply. Working only with one arm @ the moment so need to wait for some help to tear this thing apart. Going into the pump first to check the strainer.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 polaris virage tx resonator melted.
    By gnose in forum Polaris Open Discussion
    Replies: 10
    Last Post: 08-25-2017, 12:02 PM
  2. Replies: 31
    Last Post: 05-14-2015, 06:04 PM
  3. Melted the resonator
    By aceofspades in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-24-2013, 08:20 PM
  4. Power Pipe---Resonated or not?
    By FastFlow in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-04-2005, 04:18 PM
  5. New Toy "Resonator" Power Pipe
    By Jrsrxp in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-01-2005, 07:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •