Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1

    New to this, need some help after being silly

    Hi guys, as the title says I'm new to this sport I have an Rxp215 brand new 09' plate .. Ive put about 20hrs on it so far. It is loads of fun wish I got into this earlier ...
    Anyway was on the lake the other day with some friends of mine and was doing 360s, figure eights, spinning it out and stuff (wish I hadn't now). After a while it started bogging down on me. At full throttle it sits at around 7800 rpm or so but on full throttle it would hit 7800 then drop down inexplicably to 6500 and then spike up again... took it back to the ramp lifted the seat and water was up halfway to the top of the motor; it was dark anyway turned it straight back on so it was only off for a minute or two put it on the trailer and pulled the plugs to drain it.
    Planned on taking back out in two days and check it again after letting it dry out. The follow day I shattered my elbow head and severed a tendon which means I can't go on it for 6 weeks (injury from a different activity). Today so 1 week later I took it to the lake and let my brother ride it for ... From the start it was doing the same thing ... It wouldn't even accelerate smoothly spiking and bogging down... Over the next 30 min it got progressively better and then ran spot on didn't miss a beat at all for the next 2 hrs. Question is what did I do to it and should I be concerned overly about it. It runs 100% now ? .. And I think I've learnt a lesson about doing silly things over and over again .. But u need to make mistakes to learn from them I gues ... Any responses would be great thanks.


  2. #2
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Miami, FL
    Posts
    2,419
    +1
    10
    Welcome to the Hulk. Before you continue running it you need to check your oil to make sure water didn't get in there. Take out the oil dipstick and let some oil smear on top of your valve cover.(works best when you have a black valve cover). If you inhested water you will notice that the oil is a little milky. You are at the 20 hour mark so I suggest changing it anyways.

  3. #3
    Thanks for that did check it, it seemed clean to me I only changed it at 10hr but having done this I may do it again as a precaution. Any idea where I ingested it to cause the bogging down though and seeing as its cleared aside from changing oil anything else I should do? regards.

  4. #4
    idoodou's Avatar
    Join Date
    Mar 2009
    Location
    cincy,ohio
    Posts
    765
    +1
    30
    also check where the air intake hose to the supercharger go in had my slip partly off once did not notice til i got water in hull did about the same thing but water got into the oil had to do about 5 oil changes to get it all out and a boil out to dry motor good luck hope it is ok follow service manual for boil out and oil changes also water can and will trap in the in take manifold

  5. #5
    Thanks for the advice guys, I just went out to the ski and pulled the dipstick 3 or 4 times .. It isn't milky it's as it should be. If there's water in the oil will it be blatantly obvious to see.

  6. #6
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Miami, FL
    Posts
    2,419
    +1
    10
    It depends how much water was injested. I would change it just as a precaution.

  7. #7
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Yes it would be. Change the oil anyways as has already been said. Also change your plugs. Water shouldn't have got into the hull just from doing spinouts and what not. You have an issue somewhere

  8. #8
    Thanks very much guys I will definetly change the oil as a precaution. After running it about 3 hours today it only had about 50-60 ml of water come out the bungs. I'll definitely monitor it though and see if it's leaking somewhere with more spirited riding.. I'm still a bit concerned/curious as to what it was that was causing it to bog down for periods and then spike again. This site seems very helpful thanks.

  9. #9
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Quote Originally Posted by RobbieAus View Post
    Thanks very much guys I will definetly change the oil as a precaution. After running it about 3 hours today it only had about 50-60 ml of water come out the bungs. I'll definitely monitor it though and see if it's leaking somewhere with more spirited riding.. I'm still a bit concerned/curious as to what it was that was causing it to bog down for periods and then spike again. This site seems very helpful thanks.
    This was nearly definately a result of your motor ingesting water.. If you ingest enough water it can pool up in your inlet manifold and re-enter the motor on WOT. Or the sloshing of water in the hull could have caused it to ingest more through the air intake. Your spark plugs were likely damaged as a result.

  10. #10
    Okay, what should I do now that it's running fine.
    1.change oil
    2.change plugs
    (I take it I can do these 2 myself - I'll search the forum)
    What other steps should I take.
    Also seeing as we rode it for 3 hours today would(first 45 minutes problem was getting progressively better; per for final 2hrs) would all the water have gone? or what else should I do?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New to forum.Need some help troubleshooting 1999 SLH 700
    By Djward123 in forum Polaris PWC Performance
    Replies: 0
    Last Post: 08-25-2015, 11:37 AM
  2. HELP new to jetski need some help!!! 2005 gp1300r
    By mannyk727 in forum Yamaha PWC Performance (2-stroke)
    Replies: 23
    Last Post: 10-16-2014, 11:37 AM
  3. Replies: 4
    Last Post: 05-21-2013, 02:38 AM
  4. New to greenhulk need some help
    By impulsive in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 04-26-2011, 11:55 PM
  5. New to forum! need some help!
    By FzsSho84 in forum Yamaha Open Discussion
    Replies: 2
    Last Post: 02-15-2009, 02:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •