Page 1 of 6 1 2 3 ... LastLast
Results 1 to 10 of 58
  1. #1
    Will work on YOUR ski for FREE! GeoRXT's Avatar
    Join Date
    Mar 2006
    Location
    Miami, FL
    Posts
    4,438
    +1
    1

    Why do I keep fouling plugs...?

    Finally got my ski back from PPG on SAturday. Took it out for a ride the same day and the ski did not perform 100%.....Frazier told me he took it for a water test and it ran good but fouled a plug....It ran 7950rpms but di not have my gps with me for mph numbers....

    Why does this happen? I know I injested water a while back, changed the oil 3 times......should I change the oil 2 times more maybe...?


  2. #2
    mxl16's Avatar
    Join Date
    May 2005
    Location
    Central NJ
    Posts
    1,590
    ive heard of the stock ic leaking causing plugs to foul constantly.

  3. #3
    Will work on YOUR ski for FREE! GeoRXT's Avatar
    Join Date
    Mar 2006
    Location
    Miami, FL
    Posts
    4,438
    +1
    1
    Quote Originally Posted by mxl16 View Post
    ive heard of the stock ic leaking causing plugs to foul constantly.
    Like I need an excuse to upgrade the intercooler!

  4. #4
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    how does he know it fouled a plug? did it literally look fouled when removed, or was the ski just running like it was misfiring or had a fouled plug?

    i'd say i see failing coil packs more often then i see fouled spark plugs personally... similar symptoms

  5. #5
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    The slightest bit of water will cause a plug to missfire. Also check your coil pack to see if the plastic is cracked down the length of it. When u wash it down, moisture can get in the plug holes , and the coil packs can arc off the moisture if they are cracked...mine do.

  6. #6
    Will work on YOUR ski for FREE! GeoRXT's Avatar
    Join Date
    Mar 2006
    Location
    Miami, FL
    Posts
    4,438
    +1
    1
    Well I would not know man. It does seems like its misfiring a bit. But not all the time, just when I hit it WOT and when it hits top speed it does not do it anymore. Does not di it at cruising speed either...just when I accelerate.

  7. #7
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    so i dont get it... they had your ski, you had it serviced, they water tested it and it ran good but fouls plugs... so now what? they jut give it back and say yea watch out for that it fouls plugs, or are they gonna find out why? ... or was that not part of the service?

  8. #8
    Will work on YOUR ski for FREE! GeoRXT's Avatar
    Join Date
    Mar 2006
    Location
    Miami, FL
    Posts
    4,438
    +1
    1
    I'll check on that... Psycho
    Last edited by GeoRXT; 11-13-2006 at 12:23 AM.

  9. #9
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    I noticed when I had the power filter , that wave jumping would send any water in the hull to the filter. Just change the plugs, and be done with it...lol

  10. #10
    Will work on YOUR ski for FREE! GeoRXT's Avatar
    Join Date
    Mar 2006
    Location
    Miami, FL
    Posts
    4,438
    +1
    1
    It was not part of the service Steve. It was just getting the rideplate replaced remember....He told me to change the oil to make sure there is not water/moisture in the oil, change the plugs and see how it does.
    Last edited by GeoRXT; 11-13-2006 at 12:24 AM.

Page 1 of 6 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Why do I need to keep my handlebars turned to go straight?
    By XDAILY in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 06-30-2011, 02:43 AM
  2. WaveRaider 1100 Fouling plugs and how do I convert to premix??
    By RallyHawk in forum Yamaha Old School Skis
    Replies: 4
    Last Post: 09-11-2010, 10:53 PM
  3. 2003 XL700 Plug keeps fouling
    By tthimlar in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-31-2010, 07:05 PM
  4. Why do I keep getting loged off?
    By 1 FAST VE in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 10-19-2005, 02:57 PM
  5. A little OT: why do my tie-downs keep coming loose?
    By ToeSurf in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 07-01-2005, 11:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •