Results 1 to 2 of 2
  1. #1
    qbzonk's Avatar
    Join Date
    Aug 2006
    Location
    Orlando
    Posts
    975

    New Blaster hood seal issue

    I posted on the X with no response, so I figured I'd try the Hulk for some input. I just replaced my old hood seal on my '93 B1 with a seal from Watcon. Seal looks great, but when I left the hood latched over nite and opened the next morning, I noticed the imprint from the hood was only showing for the front and rear of the seal. The sides remained pretty untouched (no groove left in seal).

    Not sure if this will be an issue, but I assumed it would have made a groove all the way around the seal. See pics below:
    Click image for larger version. 

Name:	CIMG2585.jpg 
Views:	101 
Size:	52.4 KB 
ID:	230322Click image for larger version. 

Name:	CIMG2587.jpg 
Views:	94 
Size:	44.1 KB 
ID:	230323Click image for larger version. 

Name:	CIMG2586.jpg 
Views:	89 
Size:	89.9 KB 
ID:	230324Click image for larger version. 

Name:	CIMG2588.jpg 
Views:	258 
Size:	81.4 KB 
ID:	230325Click image for larger version. 

Name:	CIMG2584.jpg 
Views:	79 
Size:	42.9 KB 
ID:	230326


  2. #2
    Old Ski Insanity w/rpm500's Avatar
    Join Date
    Aug 2005
    Location
    Crystal River Fl
    Posts
    2,208
    front and rear of the 'clamshell' halfs are now held solidly with the hinge and clamps..is it possible they are too tight and now springing the sides out?...
    The sides may have sprung naturally thru years of heat and use... ...
    Test it by sprayin water into the groove with medium force and see if it actually leaks ..
    affixing an extra clamp to each side to pull it down and in would be a quick fix other than inserting wire thu the weather strip at the sides and pulling a small diam. nylon rope thru the strip to build up the inner core (if its hollow) ..
    was there a thin belt of rubber under the original to build it up slightly? (wr's used this)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New Blaster hood seal issue
    By qbzonk in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 02-22-2011, 07:59 PM
  2. New guy with two issues: Depth transducer & Flush connection
    By skikodiak in forum Sea Doo Open Discussion
    Replies: 25
    Last Post: 09-18-2006, 09:46 PM
  3. hood seal
    By RxPrider in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 09-04-2006, 10:47 AM
  4. New GPR hood/fairing colors?
    By Pistonwash in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 01-08-2006, 01:00 PM
  5. My new RXX hood came in today
    By Green Hulk in forum 4-Tec Performance
    Replies: 29
    Last Post: 10-27-2005, 01:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •