Results 1 to 6 of 6
  1. #1
    Folly77's Avatar
    Join Date
    Oct 2008
    Location
    Charleston, SC
    Posts
    2

    06 GTX SC won't start-just clicks

    Ski has sat up for a few months so charged battery and got up to ~13.5v. Reinstalled battery and tried to start but just got loud click repeated about every 0.5 sec coming from MPEM. Found some leads here on the forum so tried jumping across terminals on starter relay and engine turns over. Cleaned terminals and connections and tried starter switch again and just clicks but jumping starter relay turns engine over. Any ideas on what to check next???


  2. #2
    Everthing louder than everything else! sHALlow's Avatar
    Join Date
    Jun 2010
    Location
    Panama City, FL
    Posts
    391
    +1
    27
    replace starter relay.

  3. #3
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Quote Originally Posted by sHALlow View Post
    replace starter relay.
    + 1. Part number is 278001802 - around 40.00 or so. you can get them from the online store.

    https://www.onlinemicrofiche.com/4te...t/Viewcart.asp key in the item number and place your order. Quick and easy.

  4. #4
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Also, if you are desperate to ride, you can keep hitting the Start/Stop button and it will eventually start.

  5. #5
    Pauly C. Small Paul's Avatar
    Join Date
    Jul 2008
    Location
    Jacksonville, FL, United States
    Posts
    678
    +1
    1
    Quote Originally Posted by MSRXP View Post
    Also, if you are desperate to ride, you can keep hitting the Start/Stop button and it will eventually start.
    That depends. I had one that was going bad and it would click, click,click, start. Over a few weeks, it took more and more clicks to start. Then one day Jimmyrxp and I were on the lake and it wouldn't restart. No matter how many times I clicked. it was pretty embarrassing to get towed back for such a simple fix. Best advice is just replace it. I always tell myself, it costs a lot of money to go fast!

    Pauly C.

  6. #6
    Folly77's Avatar
    Join Date
    Oct 2008
    Location
    Charleston, SC
    Posts
    2
    Thx guys. Just ordered the relay. Should make it out next w/e!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 Seadoo GTX RFI won't crank, just clicks
    By normr in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 05-28-2015, 08:50 AM
  2. 06 RXP Wont start just clicks
    By jonthany in forum 4-Tec Performance
    Replies: 9
    Last Post: 08-17-2013, 03:15 PM
  3. My 1996 SLT 780 won't start, just clicking sound please help!!
    By smitty564 in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 07-28-2011, 08:35 AM
  4. Won't start just has loud click
    By mcp0828 in forum Polaris PWC Performance
    Replies: 14
    Last Post: 09-30-2008, 12:59 PM
  5. 06' Gtx-sc speed numbers!!!
    By goldhulk45 in forum 4-Tec Performance
    Replies: 9
    Last Post: 08-07-2006, 12:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •