Results 1 to 6 of 6
  1. #1
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,069
    +1
    790

    Need help with my X ECU and dash programming

    Guys I need some help. I have a stock X ECU and I installed it on a T-x I bought to sell without the Riva ecu and I can not get the stock X ECU to start the boat. It will just turn over and throw sensor code P0337 and just will not start. I asked about this before and most say my XECU needed to be programmed to my dash. Anyway. That is what I need.
    Will somebody out there let me know if this is correct and is there someone out there that will do it for me. (Program it)?


  2. #2
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    Austin I had the same thing in my 07 that I put a p-x ecu in. Once all of the codes were reset it was fine.

  3. #3
    yeah you have to get them Paired...ECU with Dash...one thing to try is Disconnect the dash under the hood at the front...Won't solve your problem but your ski may start....I think this works anyway

  4. #4
    you Prob already know but PO337 is No CAPS signal But CAPS Signal Detected....Two Second Beep every 15minutes...Damaged Sensor, Damaged Circuit wires, Damaged connector, Damaged ECM pins, Damaged tooth Wheel....Check for 190 to 290 ohms between Terminals A-5 and A-19 of ECM connector.....

  5. #5
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    If its the caps sensor make sure you didnt cross the water temp plug w. The caps plug. Same style and very near eachother easy to flop (kinda haha)..... been there done that

  6. #6
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,069
    +1
    790
    Thanks guys, I know it is not the sensors, but the ecu just not wanting to work with its new gauge is my thought from others here. Also remember the Riva ECU works on the ski perfect no codes.

    Anyone want to check this ecu and program it to my gauge? Ofcoarse I would line yourpocket.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: 02-29-2016, 07:19 PM
  2. Need help with my GP1200!
    By MTAINFLA in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 03-28-2008, 02:13 PM
  3. Need help with my C180
    By Atlantis in forum Sea Doo Sport Boats
    Replies: 5
    Last Post: 09-12-2007, 08:46 PM
  4. Need help with my 1050 mph
    By 1FASTXC in forum Polaris Open Discussion
    Replies: 32
    Last Post: 06-09-2007, 02:05 PM
  5. Need Help with my STLX 1050
    By Johnquest in forum Polaris Open Discussion
    Replies: 18
    Last Post: 03-15-2007, 10:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •