Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11

    Anyone running a Riva H1 wheel/SHO ?

    Any feedback on the charger?


  2. #2
    Banned User
    Join Date
    Aug 2010
    Posts
    71
    I have one just haven't ride my ski yet since I put it in .

  3. #3
    RichieFZR's Avatar
    Join Date
    Jan 2010
    Location
    Gold Coast, Queensland, Australia
    Posts
    2,093
    +1
    4
    Quote Originally Posted by WATER WOODY View Post
    Any feedback on the charger?

    Yes I have. Make sure you use a billet shaft. As on my proto typre 3 bearing H1 shaft snapped the bolt off the front and smashed my H1. Now going full custom front wheel bigger then a H1.

  4. #4
    Kristian Keppel Waterholics's Avatar
    Join Date
    Apr 2010
    Location
    Trinidad & Tobago
    Posts
    1,405
    +1
    38
    Quote Originally Posted by RichieFZR View Post
    Yes I have. Make sure you use a billet shaft. As on my proto typre 3 bearing H1 shaft snapped the bolt off the front and smashed my H1. Now going full custom front wheel bigger then a H1.
    What were some typical boost numbers for the H1 and how was it compared to the E1 ???

  5. #5
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    Quote Originally Posted by RichieFZR View Post
    Yes I have. Make sure you use a billet shaft. As on my proto typre 3 bearing H1 shaft snapped the bolt off the front and smashed my H1. Now going full custom front wheel bigger then a H1.
    I have the billet shaft.

  6. #6

    Join Date
    Apr 2006
    Location
    panama city beach 'fl
    Posts
    1,846
    +1
    9
    titanium bolt are a wonderful thing

    cd

  7. #7
    RichieFZR's Avatar
    Join Date
    Jan 2010
    Location
    Gold Coast, Queensland, Australia
    Posts
    2,093
    +1
    4
    Quote Originally Posted by Waterholics View Post
    What were some typical boost numbers for the H1 and how was it compared to the E1 ???
    I cant compare them as the E1 was on a stock Supercharger.

    The H1 was on the proto type 3 bearing shaft. The H1 spooled up really really really really FAST on the proto setup. Now using a billet shaft with a bigger wheel for phase 2 of testing. finger crossed i'm on the water this weekend.

  8. #8
    Kristian Keppel Waterholics's Avatar
    Join Date
    Apr 2010
    Location
    Trinidad & Tobago
    Posts
    1,405
    +1
    38
    Quote Originally Posted by RichieFZR View Post
    I cant compare them as the E1 was on a stock Supercharger.

    The H1 was on the proto type 3 bearing shaft. The H1 spooled up really really really really FAST on the proto setup. Now using a billet shaft with a bigger wheel for phase 2 of testing. finger crossed i'm on the water this weekend.
    Do you mean stock ECU ???

  9. #9
    RichieFZR's Avatar
    Join Date
    Jan 2010
    Location
    Gold Coast, Queensland, Australia
    Posts
    2,093
    +1
    4
    Quote Originally Posted by Waterholics View Post
    Do you mean stock ECU ???
    I run Motec. But it has nothing to do with the spool speed of the 3 bearing shaft.

    Click image for larger version. 

Name:	billit wheel.jpg 
Views:	176 
Size:	60.3 KB 
ID:	231018

  10. #10
    Banned User
    Join Date
    Aug 2010
    Posts
    71
    Spool won't change because it's a gear driven charger .
    The bearings just keep it solid in place

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. riva H1 wheel
    By Big brother in forum Yamaha PWC Performance (4-stroke)
    Replies: 27
    Last Post: 02-11-2011, 10:14 PM
  2. Who is running a RIVA B1 wheel?
    By MPower in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 05-01-2010, 05:53 AM
  3. who is running a riva b1 wheel with the ecu reprogramming?
    By gordon lasiter #328 in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 04-02-2010, 06:11 PM
  4. Anyone running a Riva CDI email me
    By Mpeavler in forum Yamaha Old School Skis
    Replies: 10
    Last Post: 04-24-2009, 02:07 PM
  5. Anyone running RXT Riva Stage 2?
    By Shibby1485 in forum 4-Tec Performance
    Replies: 12
    Last Post: 07-19-2005, 12:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •