Results 1 to 4 of 4
  1. #1
    rxpvic's Avatar
    Join Date
    Jun 2006
    Location
    Tampa, Florida
    Posts
    258
    +1
    17

    Wear Ring Problem

    I installed a new wear ring in my 2005 rxp, And it doesnt spin easy, It is not a oem one. I can turn it when on the vise but it is very hard, Does any one ever have any luck with after market wear rings? Or should I just throw it away and buy a oem one. Thanks


  2. #2
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Quote Originally Posted by rxpvic View Post
    I installed a new wear ring in my 2005 rxp, And it doesnt spin easy, It is not a oem one. I can turn it when on the vise but it is very hard, Does any one ever have any luck with after market wear rings? Or should I just throw it away and buy a oem one. Thanks
    I bought one aftermarket wear ring off EBAY. When I got it and took a look at it, I never installed it went OEM. I would use the OEM wear ring always.

  3. #3
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Quote Originally Posted by jp1300r View Post
    I bought one aftermarket wear ring off EBAY. When I got it and took a look at it, I never installed it went OEM. I would use the OEM wear ring always.
    + 1. Oem only.

  4. #4
    rxpvic's Avatar
    Join Date
    Jun 2006
    Location
    Tampa, Florida
    Posts
    258
    +1
    17
    Quote Originally Posted by jp1300r View Post
    I bought one aftermarket wear ring off EBAY. When I got it and took a look at it, I never installed it went OEM. I would use the OEM wear ring always.
    Thanks, After installing it I thought maybe I did somthing wrong and wanted to get some advice. I am going to order a oem one.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Odd Wear Ring Problem on 99XP Ltd Help me help my buddy!
    By 1 FAST VE in forum 2-Stroke Performance
    Replies: 23
    Last Post: 07-25-2010, 09:09 PM
  2. Impeller binding on wear ring.. problem or symptom?
    By NoGo1200 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 09-21-2008, 11:33 AM
  3. wear ring problems
    By RiverRat19405 in forum 2-Stroke Performance
    Replies: 0
    Last Post: 07-07-2007, 03:35 PM
  4. 2003 GTX Supercharged wear ring problems
    By Zilla57 in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 07-10-2006, 12:11 PM
  5. Odd Wear Ring Problem
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 33
    Last Post: 03-28-2006, 03:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •