Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 38
  1. #1

    Help me identify this impeller

    [ATTACH][ATTACH]Click image for larger version. 

Name:	impeller3.jpg 
Views:	57 
Size:	27.1 KB 
ID:	231592[/ATTACH][/ATTACH]I have a 2001 GPR with a Speedwerx head (150psi in all 3 cylinders) a pro-tec ride plate, intake grate,and PPK. I bought the ski like this and immediately removed the cat and installed a d-plate. I have only ridden the ski twice but the problem is I can only get it to 60mph. My stock 2000 GPR with a solas 13/19 impeller runs circles around it. With the mods it has it should be the other way around. I pulled the pump last weekend and thought I had found the problem. I thought it had the stock impeller because of the built in hex nut at the end of the prop. So i started looking for an impeller on here and that is when I ran across another members clasified ad for a nujet impeller and it too had the hex nut built into it. So now I am really confused as to what I have and why my ski wont go faster than 60. The only numbers on the impeller I see are 90501. I have googled this to try to find out what I have but no luck so I have taken a few pics of the impeller and will try to attach them to this post. I've never added pics before as I am relatively new here but will try, bear with me.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	impeller1.jpg 
Views:	60 
Size:	51.3 KB 
ID:	231593   Click image for larger version. 

Name:	impeller2.jpg 
Views:	64 
Size:	70.3 KB 
ID:	231594  


  2. #2
    Looks like attaching the pics worked, but as you can see the impeller, whatever it is isn't in the best shape so will have to be replaced regardless. If it is a Nujet any ideas as to why I'm not going faster than 60?

  3. #3
    PolarisNut's Avatar
    Join Date
    Dec 2006
    Location
    Lower Michigan
    Posts
    1,809
    That's a Nujet for sure...The thing is beat. What RPM are you running? They did make a NuJet 6.0 for stock to mildly modified boats. You either need to send that one out for repair, or start with something else.

  4. #4
    According to the stock tach it looks like im running about 7100 RPM's. That is all I have to go by. Another member is sending my a solas 14/20 to try but I think that may kill any holeshot. He said it should give me a really good top end. If that prop gives me a decent top end I was thinking of adding a jetworks holeshot kit to help with the bottom end take off. If that is a Nujet why am I only getting 60mph out of the ski?

  5. #5
    "just sayin".. jetdave56's Avatar
    Join Date
    Nov 2008
    Location
    JERSEY SHORE
    Posts
    4,494
    +1
    617
    Quote Originally Posted by yamadood View Post
    According to the stock tach it looks like im running about 7100 RPM's. That is all I have to go by. Another member is sending my a solas 14/20 to try but I think that may kill any holeshot. He said it should give me a really good top end. If that prop gives me a decent top end I was thinking of adding a jetworks holeshot kit to help with the bottom end take off. If that is a Nujet why am I only getting 60mph out of the ski?
    an aftermarket tach is really a must on this ski...whether its a Tinytach or Pet tach ,you can't be sure looking at that gauge as you ride..you should have her screaming between 7100-7300 rpms on a digital...

  6. #6

    wear ring replacement too?

    Wow the impeller's indeed beat. If the ski has a combination of higher hours say over 100, and has been run in shallow silty, or salty waters, it's recommended you check the wear ring. However, based on that prop and your plan to continue modding the ski, replacing the wear ring along with the prop is almost a no-brainer. That will have an impact on your speed...especially if you're currently having issues with cavitating... . Keep in mind it's almost 10 years old.

  7. #7
    The ski does have 97 hours on it but unbelievably it doesnt cavitate all that bad. Not nearly as bad as my 2000. Upon further inspection of my ski I found out that it does NOT have a pump seal kit. I also don't fully understand how the PV's work but i do know when I start the ski on the hose to flush it and shut it down i hear the PV motor cycling the PV's so I assume they work properly. I pulled the covers off the PV's to inspect them and found that they do not have wave eater clips so I gotta get those as well, but the PV's weren't filled up will oily goop like others I have read about on here. They were oily as they were supposed to be but no sludge so I didnt even bother cleaning them. I took pics of the PV's and the wear ring but when I reply to threads I dont get the attach image paperclip icon so I don't know how to attach pics to replies. I had no problems attaching pics when I started this thread though.

  8. #8
    I finally got the prop off today. Written in permanent marker on the inside of the hub is YM-C6.5. Can someone tell me by this description what pitch this impeller is?

  9. #9
    PolarisNut's Avatar
    Join Date
    Dec 2006
    Location
    Lower Michigan
    Posts
    1,809
    Its a Nujet 6.5. They don't measure the impellers in actual "pitch" numbers. But it loads the motor like a Concord 14/20. Too steep for your mods, unless it is depitched.

  10. #10
    Thanks Polarisnut, that was what I wanted to hear "too steep for my mods". Hopefully that in addition to the condition its in explains why my ski only hits 60mph. Bad news is someone loaned me a solas 14/20 concord to try out. I have already installed a pump seal kits and the impeller. I have purchased a solas 13/20 set back from FrankGPR so when that gets here I'm going to try that one and compare the difference in performance. Hopefully with the pump seal kit and the 14/20 prop it will run better than it did with no PPK and that beat up Nujet impeller.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help me identify this cover please
    By UnityRacing in forum Polaris Open Discussion
    Replies: 3
    Last Post: 05-07-2015, 01:20 PM
  2. Can you help me identify this SC impeller?
    By Yanksfan in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-18-2014, 10:38 AM
  3. Help me identify this red yamaha riva exhaust pipe!
    By crzyjetskr in forum Yamaha Open Discussion
    Replies: 4
    Last Post: 11-20-2011, 09:38 PM
  4. Help me identify this pump!!!
    By NZUltra in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 12-30-2009, 12:11 AM
  5. Can anyone help me with my impeller shaft and new prop?
    By ccassone in forum 2-Stroke Performance
    Replies: 0
    Last Post: 02-10-2006, 03:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •