Results 1 to 5 of 5
  1. #1

    Join Date
    Mar 2011
    Location
    jacksonville,nc
    Posts
    4

    HELP PLEASE!!!!!!!! 1994 polaris sl750

    I have a 1994 polaris sl750. IT was starting and ideling rough at high RPM and discharging alot of whit smoke. Started it yesterday on trailer with water hose hooked up it started did the usual (whit smoke, rough idel) then then died. I noticed that the emergancy cuttoff (pull cord) switch had broken I pulled it apart and fixed it and it started one more time then died. Now the engine is turning over however will not start. The gauge on the bars is blinking red (no clue what that means) and it will not start. Can anyone help me and tell me where to start. The jetski has not been in the water in over a year.

    josh


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Welcome to the Hulk Josh.

    Have you read the "my first ski: what should I do thread posted on here"?

    What do you mean it was idleing rough at high RPM?

    Did you follow the proper procedure for starting the engine, then turning the water on? And then turning the water off, and shutting the engine down in that order?

    Does any water shoot out the spark plug holes when removed and you hit the start button?

    Have you checked to see if you're getting spark when trying to start it?

    Have you checked compression?

  3. #3

    Join Date
    Mar 2011
    Location
    jacksonville,nc
    Posts
    4
    I did start water first, i am not doing that now after reading more info. I pulled the pluggs no water in there and none comming out while im hitting start, i do have spark. Thought i check compression however not so sure that i did it right. I pulled the air intake cover and looked down in the carbs and they appeare to be very clean. I check the fuel pump by pulling the discharge hose and hitting start to see if any fuel was being discharged and little to none was comming out. when it did start yesterday it would fire up and sound almost as if it was being throtled i pucked the throttle in for a couple quick burst and it climmed. when it died it slowed down and cut, the ski sat for about a year before being started.

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    No water coming out the plug holes is good.

    That ski is about 14 yrs old and will need some updating including the fuel pump, fuel filters, fuel hoses, and most likely the carbs rebuilt. All of that info is in the what should I do thread I spoke about previously. Please read that thread to get up to speed.

    Put the compression gauge in the spark plug holes, ground the spark plug wire, hold the throttle wide open, and crank the engine until the gauge stops building. What's your compression reading for all 3 cyls?

    Visually inspecting the carbs is useles, as well as using any type of carb cleaner additive. You will have to disassemble the carbs to properly inspect them.

    If the engine was running and seemed as idf the throttle was being held wide open, you may have an air leak or starving for fuel. I'd advise against running it like that as it WILL cause you engine damage.

    Try pouring a little premixed (40:1) fuel down the carb throats to see if it will start. That will help determine if it's fuel related problems you're experiencing. (which is most likely)

    I'd suggest you read up about your engine and all the upgrades that should be performed before you do any further work on it. Address the aging parts, and then see how she perfroms for you.

    At the bottom of K447 posts are some VERY useful links that will help you throughout the process, read up and learn all that you can about the Fuji (blue) engine you have in that ski.

    It can be very reliable if you maintain it. If not, you will have problems.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Welcome to the Hulk

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1994 Polaris SL750
    By Petekazel in forum Polaris Projects
    Replies: 3
    Last Post: 09-05-2011, 08:53 PM
  2. help please!!1994 polaris sl750, possible fuel pump
    By joshsims in forum Polaris Open Discussion
    Replies: 2
    Last Post: 03-12-2011, 09:59 AM
  3. FS 1994 polaris SL750
    By JimboJames in forum Polaris Skis
    Replies: 0
    Last Post: 10-22-2009, 05:44 PM
  4. 1994 Polaris sl750 all parts
    By frumpde in forum Polaris Classifieds
    Replies: 15
    Last Post: 09-02-2008, 10:12 AM
  5. 1994 Polaris SL750
    By Petekazel in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-16-2008, 10:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •