Results 1 to 7 of 7

Thread: question...

  1. #1

    question...

    have a 95 seadoo xp
    starts up and runs fine
    turn it off and it wont start anymore unless you let it set for a while with the gas off
    ... on the water you have to turn the gas off before you shut the motor off and let it run out of fuel or you will again run into the problem of it not starting for a while
    i just rebuilt the carbs and put new needles and seats in them but still the same problem
    does anyone have any suggestions?


  2. #2
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    did you clean the carb screens? sounds like you have a sticky n/s too

  3. #3
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Miami, FL
    Posts
    2,419
    +1
    10
    I am throwing a blind stone here but maybe your engine is getting flooded with fuel or the gas/oil mix is not right...like I said throwing a stone in the blind here.

  4. #4
    carbs were completely rebuilt
    and yes i know that the engine is flooding
    im just not sure what is flooding it
    sorry i didnt state that earlier

    ---------- Post added at 07:48 PM ---------- Previous post was at 07:44 PM ----------

    carbs were completely rebuilt

  5. #5
    Did you do a pop off test? What PSI did you test with?

  6. #6
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    Quote Originally Posted by tross5_13 View Post
    carbs were completely rebuilt
    and yes i know that the engine is flooding
    im just not sure what is flooding it
    sorry i didnt state that earlier

    ---------- Post added at 07:48 PM ---------- Previous post was at 07:44 PM ----------

    carbs were completely rebuilt
    Did you replace the needle/seat ??? They dont come in a rebuild kit.

    If you used any kit besides a genuine Mikuni you wasted your time & $.

  7. #7
    abarrassr07's Avatar
    Join Date
    Aug 2008
    Location
    Louisiana
    Posts
    424
    had a similar problem your having.i had a needle stuck open on my rx. had a tiny piece of metal from the carb screw broke off and jammed it open

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXT handling question
    By MPower in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-11-2009, 10:04 AM
  2. 158 Thermostat question...
    By rx4pain in forum 4-Tec Performance
    Replies: 34
    Last Post: 11-21-2008, 10:36 PM
  3. Oil Level question , this thing mixes me up :(
    By rxp_boy in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-23-2005, 10:03 AM
  4. Question for the Hulk
    By Therock in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-20-2005, 07:13 AM
  5. RXP VTS Question
    By 1FastTrespiper in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-08-2005, 10:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •