Results 1 to 7 of 7
  1. #1
    krouchchocolate's Avatar
    Join Date
    Nov 2009
    Location
    Houston, TX
    Posts
    1,223
    +1
    53

    Need help! No clue where this screw goes

    Hey Guys,

    I was removing my PTO cover to redo my flywheel bolts, and when I was putting it back together I found this screw, but I have no clue where it goes. Can you guys help me figure out the puzzle!




  2. #2
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    If its small, and takes a 5mm allen , then its a cam gear bolt.

    But, it also looks like the drain bolt from the ride plate(because of the copper washer)

  3. #3

    Join Date
    Jun 2009
    Location
    Tierra Verde, Florida, United States
    Posts
    911
    +1
    17
    Quote Originally Posted by psycho rxp View Post
    If its small, and takes a 5mm allen , then its a cam gear bolt.

    But, it also looks like the drain bolt from the ride plate(because of the copper washer)
    +1

  4. #4
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Looks like the ride plate drain bolt.

  5. #5
    A smart admits!A wicked excuses!An idiot insists! mitsakosgt's Avatar
    Join Date
    Jun 2008
    Location
    GREECE ATHENS , NAXOS
    Posts
    2,691
    +1
    40
    Quote Originally Posted by Ocman View Post
    Looks like the ride plate drain bolt.
    +1
    It is the drain bolt!

  6. #6
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by mitsakosgt View Post
    +1
    It is the drain bolt!
    +1. Remember, you pulled it out to drain the coolant. LOL. No biggie. You would have figured it out as soon as you tried to refill.

  7. #7
    krouchchocolate's Avatar
    Join Date
    Nov 2009
    Location
    Houston, TX
    Posts
    1,223
    +1
    53
    Quote Originally Posted by speedskixp View Post
    +1. Remember, you pulled it out to drain the coolant. LOL. No biggie. You would have figured it out as soon as you tried to refill.
    doh! I though I had re-installed when I removed so I could remember where it goes. Thanks for the help guys!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 07-07-2013, 07:04 PM
  2. I'm Lost, replaced grey lines and don't know where this one goes.
    By AusAnton in forum 2-Stroke Performance
    Replies: 12
    Last Post: 03-10-2012, 06:42 PM
  3. Oil Leak.... Have no clue where though.... Help!
    By GTLaser in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-14-2011, 07:00 PM
  4. Need help, no power!
    By billywilly in forum Polaris Open Discussion
    Replies: 6
    Last Post: 07-02-2007, 04:21 AM
  5. Need help, No rpm's, not charging on mfd
    By gvnitup in forum Polaris Open Discussion
    Replies: 12
    Last Post: 05-22-2007, 12:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •