Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1
    emilbolboaca's Avatar
    Join Date
    Apr 2008
    Location
    Dania Beach Fl
    Posts
    272

    TOPS problems, help please!!!

    This a 04 215hp rxp engine in a gpr hull.
    Engine had a dropped valve so it has new head wit 08 valves and it has one oversized cylinder ant two standard.
    Compression with a small battery ETX16L is 130, 110, 110psi
    I did not do a leak down test yet, I have to get a tester.

    Now this is my problem: first I have a code P1592 for VTS that is missing and the other one that I can't find a solution for is P1502. It comes on after I start the motor and rev it up, it goes up to about 7k rpms and then it goes in limp mode in 3-4 seconds. P1502 is TOPS malfunction in the manual.
    I checked the TOPS valve and it opens and closes.
    The fuses are all good.
    Then I removed the washers with seals from the TOPS valve, same thing.

    I don't know what else should I do, I feel like trowing some gas on it light it on fire.

    Please HELP


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407

    Thumbs up

    The Tops switch and valve are two different things the Tops switch is mounted to the MPEM bracket. Is your MPEM mounted vertical?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	2005 Sea-Doo Engine Service Manual.jpg 
Views:	870 
Size:	66.7 KB 
ID:	232788  

  3. #3
    emilbolboaca's Avatar
    Join Date
    Apr 2008
    Location
    Dania Beach Fl
    Posts
    272
    Yes the MPEM is like in the picture, My ski only has the small mercury switch that also has the wires on the bottom.

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    There is an arrow on the switch it should be pointing up.

  5. #5
    emilbolboaca's Avatar
    Join Date
    Apr 2008
    Location
    Dania Beach Fl
    Posts
    272
    The switch is like in the picture with the wires on the bottom. There is no arrow on it.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	2011-03-19 18.25.55.jpg 
Views:	331 
Size:	137.2 KB 
ID:	232800  

  6. #6
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    That is not the TOP's switch it should look like the the one i posted.

  7. #7
    emilbolboaca's Avatar
    Join Date
    Apr 2008
    Location
    Dania Beach Fl
    Posts
    272
    OK, this is weird. I don't see the one you sent me. What is the thing that I have in the picture then?

  8. #8
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    What year are your electronics?

    Sent from my SPH-M900 using Tapatalk

  9. #9
    emilbolboaca's Avatar
    Join Date
    Apr 2008
    Location
    Dania Beach Fl
    Posts
    272
    04

  10. #10
    Quote Originally Posted by beerdart View Post
    That is not the TOP's switch it should look like the the one i posted.
    That is a 04 Top's switch.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. DESS PROBLEM. Help please!!!!!
    By marvin1907 in forum 2-Stroke Performance
    Replies: 9
    Last Post: 06-24-2009, 09:21 PM
  2. SLT 780 Starting problem! Help Please!
    By wjstewart in forum Polaris Open Discussion
    Replies: 22
    Last Post: 05-21-2009, 08:32 PM
  3. gp1300r starting problem (help please)
    By Markb47 in forum Yamaha How To & FAQs
    Replies: 8
    Last Post: 06-26-2008, 05:05 PM
  4. 01 gtx di problems help please
    By baba850r in forum 2-Stroke Performance
    Replies: 1
    Last Post: 06-25-2008, 04:36 AM
  5. problem help please put hole in hull
    By mikegpr03 in forum Yamaha How To & FAQs
    Replies: 1
    Last Post: 12-31-2006, 12:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •