Results 1 to 6 of 6
  1. #1
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128

    08 TX motor in 06 RXP hull?

    A friend has a nice 2006 RXP with a blown motor, but everything is there, ECU, wiring, display, etc. He also has a motor/ECU out of a 2008 RXTX ... Just wondering what would need to be changed to make this motor work in the 2006 RXP? Is the wiring different, which ECU should be used, do the ECU and display need to be same year, or?


  2. #2
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    The only diff is the wiring and ecu so wich ever wiring he uses he will need to use that ecu and dess. Dislays are different also but can use either but if using 08 display with 06 harness it will need to be hookesd to buds. Easiest way to do the swap would be to leave all 06 electrics. Bur if he has all the 08 electrics and wiring I would go with that as it is more refined and more used ecu options available if ever upgrading

  3. #3
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    Thanks for the input! I think that is the route to go too ... put the 08 longblock in, but use the 06 harness, ECU and display. That would be the easiest, I just was not sure if we would have any issues doing that.

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    I would use the 08 harness, ECU and gauge its a much simpler set-up without the MPEM.

  5. #5
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    Quote Originally Posted by beerdart View Post
    I would use the 08 harness, ECU and gauge its a much simpler set-up without the MPEM.
    My bad ... found out he does not have the 08 ECU, so we will need to go 06 on the harness/ECU/display. What year did the MPEM disappear?

  6. #6
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    O6 was the last year for the MPEM.

    http://www.greenhulk.net/forums/show...=1#post1626850
    Quote Originally Posted by Vern View Post
    My bad ... found out he does not have the 08 ECU, so we will need to go 06 on the harness/ECU/display. What year did the MPEM disappear?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 06 Rxt swap in 04 Rxp Hull
    By grinchmonster2000 in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-07-2016, 06:32 PM
  2. 08 water box in 06 rxp - how to plumb it?
    By TheGunMan in forum 4-Tec Performance
    Replies: 12
    Last Post: 08-17-2013, 06:07 PM
  3. Possible blown motor in 06 RXP????
    By MVR 155 in forum 4-Tec Performance
    Replies: 0
    Last Post: 06-02-2008, 07:41 AM
  4. 05/06 RXP hull.
    By JordanHaye in forum 4-Tec Performance
    Replies: 0
    Last Post: 03-04-2007, 01:47 PM
  5. gp1300r motor in a gp1200r hull
    By superramjet in forum Yamaha Open Discussion
    Replies: 2
    Last Post: 02-18-2007, 12:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •