Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Join Date
    Apr 2008
    Location
    Tampa, fl
    Posts
    32

    Particles in the oil?

    I changed the oil in my '06 rxt I picked up last summer for the first time and I noticed some particles suspended in the oil that caught the light sorta like glitter. It wasn't too much but something I noticed in the siphon tube when staring at it for suction. Is it engine wear? Washer dust? Or anything abnormal?


  2. #2
    dnielsen's Avatar
    Join Date
    May 2008
    Location
    Shreveport, Louisiana
    Posts
    2,018
    +1
    94
    Quote Originally Posted by yamadoo View Post
    I changed the oil in my '06 rxt I picked up last summer for the first time and I noticed some particles suspended in the oil that caught the light sorta like glitter. It wasn't too much but something I noticed in the siphon tube when staring at it for suction. Is it engine wear? Washer dust? Or anything abnormal?
    Be sure its not just air suspended in the oil from the siphon. You might be able to strain the oil through a coffee filter to see if you can trap anything. If its any type of metal its not good, if thats the case your looking at an engine thats soon to fail.

  3. #3
    Kiwi spanner handler
    Join Date
    Dec 2007
    Location
    Christchurch NewZealand
    Posts
    579
    +1
    13
    I always spread the oil filter paper when doing a service and that tells you more about the engine. As above the siphon can airate the oil a bit making it look different.

  4. #4
    if you didn't like that then don't open your oil filter, but i've never seen it in the syphon tube

  5. #5

    Join Date
    Apr 2008
    Location
    Tampa, fl
    Posts
    32
    Hopefully it's nothing, but I'll pay extra attention to the filter next time after I clock more rides to justify another oil change

  6. #6
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Do you not have filter that you just pulled out?
    If you left it in You can check the filter and put it back in NP.

  7. #7

    Join Date
    Apr 2008
    Location
    Tampa, fl
    Posts
    32
    Quote Originally Posted by skoepp View Post
    Do you not have filter that you just pulled out?
    If you left it in You can check the filter and put it back in NP.
    No the filters long gone, I changed the oil a couple weeks ago. I still have the oil but it's diluted in the jug.

  8. #8
    For what it's worth I have the twin 215's and thought the same thing. It appeared to be silvery glitter. Again only if the light hit it right. I though the engine was F&^%@ because I hadn't swapped the washers...yet. Still not sure it may be an additive to the oil. Engine runs fine

  9. #9
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    Its more likely to be residue from the supercharger clutch washers, I seen it before as long as its not brass looking shavings your are okay.

  10. #10
    maestro's Avatar
    Join Date
    Aug 2008
    Location
    GR
    Posts
    139
    Quote Originally Posted by ultramaxracing05 View Post
    Its more likely to be residue from the supercharger clutch washers, I seen it before as long as its not brass looking shavings your are okay.
    +1

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How can you tell if you have gas in the oil?
    By carolinafloats in forum Kawasaki PWC Performance (4-stroke)
    Replies: 7
    Last Post: 08-31-2007, 03:41 PM
  2. Ultra 250 Gas in the oil.........what I am doing.....
    By Hurricane1000 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 23
    Last Post: 08-23-2007, 07:44 PM
  3. Water in the oil after waterbox mod!!
    By BHolley in forum 4-Tec Performance
    Replies: 6
    Last Post: 04-29-2007, 08:55 AM
  4. water in the oil cup
    By JCM in forum 4-Tec Performance
    Replies: 2
    Last Post: 04-18-2007, 05:27 PM
  5. metal shavings and particles in my oil filter
    By rapidacceleration in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 01-28-2007, 02:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •