Results 1 to 7 of 7
  1. #1

    Took the ski out for the first time today..some questions

    We had a warm day here on Table Rock and I took my bone stock 06 gp1300r out. It was about 80*, and water temp was probably in the 60s. I had a full tank of gas, and was able to hit 60mph on the gps. I weigh 182lbs. This was in choppy conditions. The best spot for the trim seemed to be halfway between neutral and all the way up. Does this sound about right for bone stock? Seems to pull real good up top.

    One issue I noticed is that coming out of hole is horrible. It just doesn't seem to want to hook up and just bouncing limiter basically until about 10-15mph. I would try to do a tight turn from a stop to jump my own wake, and it was basically impossible. I have road 10 year old 3-seater sea-doos that came out of the hole better than this. Is this normal for stock? What mods do I need to do to fix this?

    Thanks!


  2. #2
    Just relax and enjoy the ride. XLT Chad's Avatar
    Join Date
    Jan 2011
    Posts
    1,284
    +1
    116
    K-Dubb, Your cavitating. A pump plug kit will usually take care of this. Also check your wear ring and prop while your in there.

  3. #3
    Quote Originally Posted by XLT Chad View Post
    K-Dubb, Your cavitating. A pump plug kit will usually take care of this. Also check your wear ring and prop while your in there.
    I appreciate the quick response. Is the pump plug kit the same as a pump seal kit that I am seeing? The ski has 57 hours on it. Thanks.

  4. #4
    Just relax and enjoy the ride. XLT Chad's Avatar
    Join Date
    Jan 2011
    Posts
    1,284
    +1
    116
    http://www.4-tecperformance.com/inde...roducts_id=153
    easy to install, check the how to's if your not sure.

  5. #5
    "just sayin".. jetdave56's Avatar
    Join Date
    Nov 2008
    Location
    JERSEY SHORE
    Posts
    4,494
    +1
    617
    Quote Originally Posted by XLT Chad View Post
    K-Dubb, Your cavitating. A pump plug kit will usually take care of this. Also check your wear ring and prop while your in there.
    yes...all of the above...prop might need reconditioning after 57 hrs ,it has least a few dings...the GPR has a bad holeshot with its large waterbox...a jetworks mod will help this greatly....lots of info and "how to" on the efi GPR and what you can do to improve performance speed and realiabilty,search around...

  6. #6
    Thank you everyone. I will check out the how-to. On the impeller, Am I just looking for dings and such? I guess I can find more info about what to check on the wear ring, or what it even is in the how to as well?

    After doing some searching, I have read like you said that the holeshot is not that great on these, but mine must have something else wrong (I am sure something already stated above) because there is no way they could sell this thing like this!

    Thanks.

  7. #7
    Superman! fivespeedsteed's Avatar
    Join Date
    May 2010
    Location
    Midlothian VA
    Posts
    1,058
    +1
    14
    Quote Originally Posted by K-Dubb View Post
    Thank you everyone. I will check out the how-to. On the impeller, Am I just looking for dings and such? I guess I can find more info about what to check on the wear ring, or what it even is in the how to as well?

    After doing some searching, I have read like you said that the holeshot is not that great on these, but mine must have something else wrong (I am sure something already stated above) because there is no way they could sell this thing like this!

    Thanks.
    on the impeller just make sure that there are no chunks missing, or rough spots, or any other thing that might be abnormal. what your measuring here is the clearance between the outermost edge of the impeller and the wear ring. if you shine a light at it in the dark you will see where light can pass through it between this gap. you will need a feeler gauge to tell. i think (*think*) if i recall correctly that its .20 or more and you need a new wear ring. if this is more than the specified amount then water is rushing around the impeller and not getting blown back like it should and will hurt your holeshot more. i have the same condition as you, and im getting ready to seal my shoe and do an intake grate and all.

    make sure you check out uscme's build thread in the projects section, he walks you though allot of things.

    also if you havent already check out this site

    http://www.cajundude.com/jetskihome.htm

    he walks you through many of the basic mods done to GPRs with a good picture by picture documentation. i think that link is down for the service manual on his site, but the service manual is a great thing to have. you will need to know torque specs and all on bolts, and it will tell you tolerances for the impeller and wear ring, and other things like the crank and how to adjust the motor on its mounts, ect.

    if the link is down search around some its on another site

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Took my ski out for its first test ride. :)
    By Fosta in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-23-2015, 12:51 PM
  2. Replies: 15
    Last Post: 03-28-2013, 12:59 AM
  3. Replies: 8
    Last Post: 05-24-2011, 08:02 PM
  4. So... I had the ski out for the first time today...
    By GeordieBoyKel in forum Polaris Open Discussion
    Replies: 23
    Last Post: 01-26-2009, 03:00 PM
  5. took the new rxp out for the first time today
    By mxl16 in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-17-2005, 08:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •