Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1
    RichieFZR's Avatar
    Join Date
    Jan 2010
    Location
    Gold Coast, Queensland, Australia
    Posts
    2,093
    +1
    4

    POP goes the cooler!!

    Click image for larger version. 

Name:	coolercrack.jpg 
Views:	86 
Size:	57.6 KB 
ID:	233118

    For those of you thinking Im not pushing big boost....... here's PROOF!

    thats why my hull filled up with water.....lol

    I was going to post it in my other thread , but people could've missed it.


  2. #2
    Phil.Borg's Avatar
    Join Date
    Aug 2009
    Location
    Sydney AUS
    Posts
    403
    +1
    3
    that is a bummer mate

    what boost numbers were u seeing before this?
    do u think this was your problem with not seeing boost and not your bov?

  3. #3
    RichieFZR's Avatar
    Join Date
    Jan 2010
    Location
    Gold Coast, Queensland, Australia
    Posts
    2,093
    +1
    4
    Quote Originally Posted by SQURTN View Post
    that is a bummer mate

    what boost numbers were u seeing before this?
    do u think this was your problem with not seeing boost and not your bov?
    We had 22psi dialed in. No the BOV was letting the boost out, not holding the boost inn... LOL

  4. #4
    Phil.Borg's Avatar
    Join Date
    Aug 2009
    Location
    Sydney AUS
    Posts
    403
    +1
    3
    ok not cool
    so will u still be going with that cooler setup have you had a look a one of garys coolers there quiet big
    im also pushing hi boost through one of these and not a problem
    just a thought mate

  5. #5
    coldspace's Avatar
    Join Date
    Feb 2009
    Location
    Brisbane, Australia
    Posts
    438
    Ah the joys of high mods, is there any corrosion causing it to weaken? are you going to weld it or try something else?

  6. #6
    RichieFZR's Avatar
    Join Date
    Jan 2010
    Location
    Gold Coast, Queensland, Australia
    Posts
    2,093
    +1
    4
    Quote Originally Posted by SQURTN View Post
    ok not cool
    so will u still be going with that cooler setup have you had a look a one of garys coolers there quiet big
    im also pushing hi boost through one of these and not a problem
    just a thought mate
    The only front cooler I would run would be a JD cooler. I will be going back to front cooler after all the new charger tests are done.

    Quote Originally Posted by coldspace View Post
    Ah the joys of high mods, is there any corrosion causing it to weaken? are you going to weld it or try something else?
    There is no corrosion , just cracked under pressure. Dean has another cooler sitting as his that I am going to get my hands on. smaller but still big for air flow.

  7. #7
    rick xp's Avatar
    Join Date
    Jul 2007
    Location
    Brisbane, Australia
    Posts
    1,013
    +1
    7
    Just weld it up richie and keep going son...

  8. #8

    Join Date
    Jan 2011
    Location
    Brisbane Australia
    Posts
    152
    Quote Originally Posted by RichieFZR View Post
    The only front cooler I would run would be a JD cooler. I will be going back to front cooler after all the new charger tests are done.

    Just wondering why the only cooler you would run up front would be the JD cooler ?

  9. #9
    Kelly_A's Avatar
    Join Date
    Dec 2009
    Location
    Central Oklahoma
    Posts
    660
    +1
    17
    Am I missing something here? If that's the cause of the hull fill, wouldn't it indicate a leak due to water pressure rather than air pressure?

  10. #10

    Join Date
    Oct 2007
    Location
    Brisbane, Australia
    Posts
    1,538
    +1
    3
    .
    Last edited by Gunna; 03-22-2011 at 03:22 PM. Reason: .

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. POP Goes the 09 RXT-IS
    By bluesun in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 04-30-2012, 05:45 PM
  2. Pop Goes the PTO!!!!
    By steach in forum Yamaha PWC Performance (2-stroke)
    Replies: 25
    Last Post: 01-03-2009, 09:05 AM
  3. Kaboom goes the 1300
    By shooter98xpl in forum Yamaha PWC Performance (2-stroke)
    Replies: 57
    Last Post: 10-28-2008, 08:16 AM
  4. Snap goes the pump stud!
    By whit33 in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-01-2007, 12:45 AM
  5. Moranic Mistake - Down goes the 1200XLL - Need some thoughts!
    By snowrunner in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 05-28-2007, 08:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •