Results 1 to 5 of 5
  1. #1

    ultra 150 battery

    My 04 ultra 150 is draining the battery while sitting for a week. The battery is new,the key is turned off,and kill switch key is removed.and still battery is run down, once I jump it its good for the week end .Any help would be appritiated.


  2. #2
    DILTS's Avatar
    Join Date
    Aug 2010
    Location
    SOUTHEAST TEXAS
    Posts
    112
    +1
    4
    I feel your pain. I have this problem with two of my Ultra's. I have had both of them gone over by my local Kawi dealer and found nothing. It has been going on since 03. What I have to do when I am done riding for the weekend it disconnect the battery leads and keep a trickle charger on them while they sit. I haven't had to replace a battery for the last 4 years. I could never find what was drawing power from the battery killing them. Sorry, but I know it's not what you wanted to hear, but that's how I resolved the issue.

  3. #3
    captainoverspray's Avatar
    Join Date
    Jan 2009
    Location
    Milwaukee, Wisconsin, United States
    Posts
    302
    I just took a quick look at the wiring diagram in the service manual and the orange ignition switch does not turn off the electrical system. It only turns off the lead to the CDI and the Start button. You have a drain somewhere in the system. I would install one of these inline with the battery lead if you can not find the draw. http://www.amazon.com/US-General-Bat.../dp/B001R6UIBC

  4. #4
    DILTS that is what I have been doing but its getting old disconecting/conecting the battery every time I go out.
    Captain thanks for the idea of a battery diconecting switch I just may get one.

    Thanks

  5. #5
    DILTS's Avatar
    Join Date
    Aug 2010
    Location
    SOUTHEAST TEXAS
    Posts
    112
    +1
    4
    I agree it does get old, but i found it's better for me to spend the ten minutes than drive to the lake an hour and a half away to ride and find a battery dead. I looked into those last year, but obviously not enough I couldn't find one that wasn't heavy or to big. I believe the Captian is on to something here.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 kawasaki ultra 150 battery wiring problem
    By Crodgers14 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 11
    Last Post: 12-23-2014, 11:41 PM
  2. Ultra 150 battery terminals
    By Kawa_Fan in forum Kawasaki How To & FAQs
    Replies: 2
    Last Post: 07-23-2014, 10:04 PM
  3. Ultra 150 battery tie down question
    By xxpaul17xx in forum Kawasaki PWC Performance (2-stroke)
    Replies: 4
    Last Post: 07-07-2012, 10:27 PM
  4. 04 ULTRA 150 Battery Issues
    By tonybb in forum Kawasaki How To & FAQs
    Replies: 4
    Last Post: 06-26-2010, 06:39 PM
  5. Ultra 150 Battery not charging/battery light flashing
    By kcoleman10 in forum Kawasaki Open Discussion
    Replies: 5
    Last Post: 02-13-2009, 01:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •