Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: rxp wont start

  1. #1

    Join Date
    Mar 2011
    Location
    prince edward island canada
    Posts
    2

    rxp wont start

    ok i am new to the see doo world i have a 2005 rxp it works awesome but i left it set for a bout two weeks went to start it and it does not even beep i mean nothing i have a new battery but i can hear a click click noise i checked the fuses in the front but they r good what else could it be is my post gone or did my layerd loose its memery aney help would be great guyes thanks


  2. #2
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Does the display power on? Do you hear a click when you hit the start/stop button? If so, then your starter relay is bad and needs to be replaced! Fill us in with the other information to better help you.

  3. #3
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    check, and (remove & clean) the 2 main red wires on the brown selenoid next to the MPEM

  4. #4

    Join Date
    Nov 2007
    Location
    Lincoln, NE
    Posts
    332
    Try charging it mine did the same thing. oh and welcome to GH it's a great site you will soon find out!!!!!

  5. #5
    dnielsen's Avatar
    Join Date
    May 2008
    Location
    Shreveport, Louisiana
    Posts
    2,018
    +1
    94
    I had this issue a few years back, turned out to be the starter needed to disassembled and cleaned. Lasted a little while before I had to replace it.

  6. #6
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    Having a click sound is a good sign you dont have a mempem problem or ecu issue. sounds like either a starter or the relay I had a issue that it would not do anything ending up being a tps/ecu problem

  7. #7
    tick.. tick.. RXPteamtimebomb's Avatar
    Join Date
    Jan 2007
    Location
    Maryland
    Posts
    726
    +1
    13
    +1 on starter relay.. been there.. click click, $30 and new starter relay and started right up.. you could also test to see if it is a bad starter relay by touching or making the two terminals on the relay touch using a rubber or plastic handled screw driver.. with the key in and lay the screw driver to connect the two and if the ski starts then its a bad starter relay
    TJ

  8. #8
    5.0. alex_baker202's Avatar
    Join Date
    Aug 2007
    Location
    Lebanon, Missouri, United States
    Posts
    1,027
    +1
    24
    Quote Originally Posted by RXPteamtimebomb View Post
    +1 on starter relay.. been there.. click click, $30 and new starter relay and started right up.. you could also test to see if it is a bad starter relay by touching or making the two terminals on the relay touch using a rubber or plastic handled screw driver.. with the key in and lay the screw driver to connect the two and if the ski starts then its a bad starter relay
    TJ
    +2. Mine did same thing. It should be the brown plastic box next to all the fuses closer to the gas tank that has two red cables attached to it.

    I tested mine by removing both red cables and putting the key on... Then I touched the two wires together and the motor turned over. You can also try to jump across the connections if you know how..(explained in the above post).... This is how I found mine was bad.

  9. #9
    skiskeet's Avatar
    Join Date
    May 2010
    Location
    union nj
    Posts
    47
    had the same problem on my rxt it was the starter relay

  10. #10

    Join Date
    Mar 2011
    Location
    prince edward island canada
    Posts
    2
    ok guyes thanks i will try all of the stuff you guys said to try but when i put the key in i get nothing on the dash it dont beep at all and dont come on just tell me what ya need to know i will be happy to tell ya what ever and thanks again

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help 04 Rxp wont start
    By region8racer in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-17-2009, 11:40 PM
  2. Help 04 Rxp wont start
    By region8racer in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-13-2009, 04:52 PM
  3. 06 RXP wont start?
    By Stainless in forum 4-Tec Performance
    Replies: 4
    Last Post: 06-03-2009, 09:09 AM
  4. 06 Rxp wont start
    By Antiguan FZR in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 03-31-2008, 04:54 PM
  5. RXP wont start
    By werdnash2002 in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 07-21-2005, 11:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •