Results 1 to 5 of 5
  1. #1

    Help ! 1999 Polaris Genesis Ficht

    Machine wont start. I have spark but no fuel going into cylinder. Fuel getting to injector. How can i test injector?

    Should i have voltage to the injector?

    Could the EMM be causing this problem?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Welcome to the Hulk

    You will need to do some diagnostics. The links in my signature will prove helpful.

    Check the voltage on White/Red wire without unplugging any injectors. Should be over 20 volts with engine cranking.

  3. #3
    Thanks for help k477. I primed cyclinders and engine started and ran. I checked voltage at Fi injectors and was getting 16 to 17 volts. After starting engine and turning off i was getting over 20 volt. Tried to restart and wont start. Checked voltage reading again ,16 to 17 volts. Not sure about next thing to do. Should i have emm checked. I dont have a spare.

  4. #4
    jackofalltrades's Avatar
    Join Date
    Aug 2010
    Location
    Cabot Arkansas
    Posts
    592
    If you have a spare put it in there and see if the problem goes away. One thing to note is the fuel injectors are flow mapped to the EMM so installing your spare is ok to test it and see if that is the problem but you would need to have the injectors mapped if you wished leave that EMM installed.


    Disregard.. I didnt read your post right. I thought you had a spare. .........

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Quote Originally Posted by Taz man View Post
    ... I primed cylinders and engine started and ran.

    I checked voltage at FI injectors and was getting 16 to 17 volts.

    After starting engine and turning off I was getting over 20 volt..
    Under 20 volts before starting? That is too low for the injectors to actually inject fuel. Which is why it started when you primed it. Once the engine starts, the RPM rises and the weak EMM can put out more voltage.

    Voltage after turning off doesn't matter much. Other than it should decay slowly.

    Voltage while running should be around 45 volts, and be fairly stable.

    At this point, the EMM is the prime suspect.

    If you want to be sure, you can check the stator and flywheel for signs of damage. Sometimes the flywheel will loose a magnet and the loose pieces then cause further damage.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1999 Polaris Genesis FICHT fuel pump has no power
    By bekbek in forum Polaris Tech Tips and Info
    Replies: 5
    Last Post: 06-26-2015, 12:02 PM
  2. 1999 polaris genesis ficht won't idle
    By rstef77777 in forum Polaris PWC Performance
    Replies: 2
    Last Post: 02-28-2013, 09:50 PM
  3. 1999 polaris genesis ficht has occasional miss or hiccup
    By buzzard one in forum Polaris Open Discussion
    Replies: 7
    Last Post: 02-28-2013, 05:37 PM
  4. No start - 1999 Polaris Genesis Ficht
    By Taz man in forum Polaris How To & FAQs
    Replies: 26
    Last Post: 07-19-2011, 08:35 PM
  5. 1999 Polaris Genesis Carb model need help with this one also
    By scottyboat in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-17-2007, 10:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •