Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: New prop?

  1. #1

    Join Date
    Aug 2005
    Location
    dallas Tx
    Posts
    17

    New prop?

    Ok my seadoo tech has determind supercharger clutch is fine. He says wear ring is actually ok. He thinks my loss of rpms is due to a couple of hardcore dings in the prop. My question is Does anyone on this board believe that a f-ed up prop could cause 15mph loss and loss of 1500rpms?
    If so please explain, as i think a messed up prop would be able to spin faster and crank more rpms and cause caviation. Here it is jsut simply not the case. I'm getting severely frusterated with this seadoo. Have 25 hours on it, havnt seen 72 since 10. And what prop would you get and why?


  2. #2
    Moderator Franko's Avatar
    Join Date
    Apr 2005
    Location
    Dallas, Texas
    Posts
    3,829
    +1
    2
    I've had some F'ed up props in my day but I have never lost 15 mph or 1500 RPM. Which shop in the Dallas area do you go to? Did he tell you how he determined your clutch is fine?

  3. #3

    Join Date
    Aug 2005
    Location
    dallas Tx
    Posts
    17
    im using sherman powersport, hes the only seadoo certified tech there, and he's doing it as sidwork. He did the clutch slippage test with the tool or whatever

  4. #4
    Take off the pump and look at the impeller

  5. #5
    Moderator Franko's Avatar
    Join Date
    Apr 2005
    Location
    Dallas, Texas
    Posts
    3,829
    +1
    2
    Quote Originally Posted by tgstk
    im using sherman powersport, hes the only seadoo certified tech there, and he's doing it as sidwork. He did the clutch slippage test with the tool or whatever
    Wow, a dealer tech who actually did the job correctly. I doubt the prop is responsible for that big of a loss in speed and RPM, but I could be wrong. Unless it is missing a blade or something. Where do you ride mostly?

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,962
    +1
    1,889
    I would put money on it that the supercharger clutch is bad despite him saying it's good.

  7. #7

    Join Date
    Jul 2005
    Location
    Wisconsin
    Posts
    128
    Yep I would ask him how he knows how the clutch is good! If the inch lb torque is below 60 inch lbs its slips above 7800 RPM. At 8100 RPM it needs to be 70+ inch lbs min.

  8. #8

    Join Date
    Aug 2005
    Location
    dallas Tx
    Posts
    17
    I will ask him bout the torques weights. Theres no reason for him to screw me tho, he's doing this as sidework. He works at sherman powersports, but he picked the boat up for me outside of the shop since it was a holiday weekend. I'm starting to wonder if this is a lemon or not, or if lemons even exist on the water. My next move to say thats f'ed up is the driveshaft, but this would make no sense as the wear ring is in exceptional condition. too me it makes no sense. It has all the fins intact on the impeller, no blades are missing, just small slight dings in the blade. The tech says that the dings create drag, keeping the engine from passing more water, thus limiting its speed. To me tho, if there was drag then the rpms should actually exceed like be hitting the rev limiter and going 15mphs slower, but i am told this is incorrect. So i guess the drag keeps the impeller from passing more water or making more speed requiring the engine to move faster ie. more rpms producing more boost, getting it up to 70.

    Ok im just talking outloud now, but this theory is still fishy. If it was an internal engine problem wouldnt i have known by now? Ie. bent rod, snapped valve, misfire, plugs, w/e.

    I really dont think i can afford the new prop till next season, so im praying this is not the reason and it seems to be not the reason, but someone either prove me wrong or prove me right please!!!! Help!!! I'm about to sell it or sink it cuz of this shit

  9. #9

    Join Date
    Jun 2005
    Location
    Cayman Islands
    Posts
    705
    I have the riva stage 2 used the solas 14/19 for two weeks turning 8100rpm all day, this prop has alot of dings on every blade and I never lost any rpm I have to disagree with your tech.
    I installed the 15/20R and turning 7750rpm max now.

  10. #10

    Join Date
    Aug 2005
    Location
    dallas Tx
    Posts
    17
    Ok.......so what is your idea or suggestion as to what the reall underlying problem is? Seruisly here........its 22 hours old. Has correct Oil. Correct plugs. As far as i know wont know till later tommorow supercharger clutch is fine. Only thing in question is the prop. So heres a new fresh idea, TOPS? do you ahve to hook it up to the computer to get it disabled? Is there any electronic problems or computer problems that could be governing my sea doo?

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Repitched prop vs. Brand new prop
    By Kinchyle in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-04-2006, 08:03 PM
  2. Can anyone help me with my impeller shaft and new prop?
    By ccassone in forum 2-Stroke Performance
    Replies: 0
    Last Post: 02-10-2006, 03:45 PM
  3. I want a new prop for Christmas
    By RichGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 12-08-2005, 09:40 AM
  4. RXT and my new prop
    By Kinchyle in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-27-2005, 09:06 PM
  5. Ran with new prop pitch, great results.
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-16-2005, 12:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •